Wr Jetting Info Please?

How's it goin? i have an 05 wr 450 with all free mods (boy this seems to be starting out like every other idiots HELP ME POST,sorry) i put the gytr ais/jet kit on it with one exception i never put the new adjustable needle in. my bike runs great except for a slight bog on the low end i have also my fuel screw is 1.5 turns out, my bog never really bothered me until i rode my buddy's 06 with a boyesen quickshot and his response was phenomenal, but after doing some TT research it seems like a waste of money could my laziness of not putting in my new needle be the cause of my bog? Also could replacing my leakjet with a # 40 cure my problem along with my needle? which position should my clip be in? and is the quickshot a waste? i ride in 40 to 90 degree weather (when it meltsuntil it freezesagain) and I never change my jets. oh I live in michigan.some help please my bog was never severe enough to bother me until now,and i can't sleep thinking that my perfect running rocket could be that much better. sorry for takin up so much space. Thanks guys. Dan

When it comes to jetting I have to remind myself of the 80/20 rule. That is 80% of the results come from 20% of the work. A JD Jet kit is a perfect example. A main, a needle and a clip position will get you your 80% increase and most of the performance you seek. To get that last 20% out of the equation will require the inverse of time put into it. If you love to wrench and test, or you're a pro rider with your own mechanic, then it may be worth the time and investment. Most people will never get the perfect tune out of there carb. I say just ride it like you stole it and have fun!

I bought a WR450 that had alot of gum/vernish in the carb from sitting too long. It did not take me long at all to clean it, and message/modify the stock accelerator pump to shoot gas when the throttle was fast opened. Take your carb off, and manually open the throttle fast, and see if you are getting the pump shot. I had to grind down the rivot on the pump diaphram and also had to rotate the spring linkage a little. Now mine has zero bog, and is a dream to ride.

I would definately spend the time to get this right, as alot of riding situations require instant response to get out of trouble.

Im frustrated with the WR stutter on my bike.

I leaned it out and I disconnected the TPS which only helped a little

Im frustrated with the WR stutter on my bike.

I leaned it out and I disconnected the TPS which only helped a little

Hey Max, try adjusting your TPS to factory specs instead of disconnecting it. I adjusted mine and all is well.

thanks alot guys. has anyone tried that boyesen a/p cover? and would changing my leak jet , and or needle position help the bog?

Hey Max, try adjusting your TPS to factory specs instead of disconnecting it. I adjusted mine and all is well.

I am an electrical failure Yamageezer. I had a tough time installing my dual sport kit.

I noticed very little when I disconnected it. I cant imagine it doing much with an adjustment.But then again. My bike has the surge and your bike doesnt

thanks alot guys. has anyone tried that boyesen a/p cover? and would changing my leak jet , and or needle position help the bog?

I have used the Boysen Quick Shot and I can take it or leave it. The AP can be adjusted with a different leak jet. The Boysen Quick Shot increases the pressure/volume of the squirt coming out the AP. A smaller leak jet will do the same thing. You may need to adjust the AP duration to make sure it squirts enough or not too much.

Is there an easy way to do needle adjustments without taking off subframe on 06 WR450

I am an electrical failure Yamageezer. I had a tough time installing my dual sport kit.

I noticed very little when I disconnected it. I cant imagine it doing much with an adjustment.But then again. My bike has the surge and your bike doesnt

I disconnected my TPS and I didn't notice a change either but when I checked the voltage it was at about 0.33 volts DC. So after I adjusted it and leaned out my pilot circuit it cleaned the quarter throttle stumble right up. :thumbsup: I think the factory setting is 0.65-0.75 volts DC or somewhere around that. Check in your service manual and do a search ( in this Forum) on how to do it. It's allot easer than installing a dual sport kit. I hope this helps and if it doesn't well at least you can eliminate this as your problem. :):ride:

Oh yeah, you might want to ask Clark4131, I think he knows where to find the how to.

how do i adjust the duration of the a/p pump?

how do i adjust the duration?

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now