HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
GetSumBaby

Rekluse ?'s for those that have one..

19 posts in this topic

I have the Rekluse and have been using the heavy spring pretty tight. I was getting what I thought was a bog, but now think its because I'm using the wrong spring. I ride mostly fast trail/ single track. Am I using the wrong spring for my type of riding?

What type of riding you do and what spring?

Thanks,

Ed

Share this post


Link to post
Share on other sites

I have been very happy with my light spring, adjusted so there is almost no slack with the engine off. I ride / race desert from sand, whoops, long loose hill climbs, tight technical hill climbs and trails, fire roads, MX tracks at the GP races, and the occasional "get off and push" through the rocks! :applause: I love mine!!

'01 426

:applause:

Share this post


Link to post
Share on other sites

Exactly, use the lighter spring. Lighter spring = less revs to engage, heavier spring = more revs to engage. The bog issue shouldn't have anything to do with spring though. If its hesitating, its a carb thing.

Share this post


Link to post
Share on other sites

I'm tight trails and hare scrambles so I use the lighter spring so it engages right off of idle. Like 080 says it's most likely your carb settings...I don't see how the Rekluse could create a bog.

Share this post


Link to post
Share on other sites

I had never noticed any carb issues with my 2006 YZ450F until after installing the Rekluse Z-pro. The bike had a tendency to cough and then die coming out of tight corners after the clutch was installed. I tried to adust around on the carb and didnt have any luck with it.

I then sent the carb to Zipty for their FCR carb mod and I've not had the issue since.

Share this post


Link to post
Share on other sites

I put a rekluse in mine. never had any problems before. But the first day to the track with it, I got vapour lock because the gas tank vent did not...

Just a coicidence. Just the way thigs go in my like

I think you either have carb bog or it is just the way your clutches engage (what rpm and how much power the motor makes at the rpm). With a manual clutch, you tend to find the sweet spot before you let the clutch out, in corners etc. The rekluse just egages when the centrifigul forces are high enough. I know from my own riding, I would run the motor up higher when fanning he clutch.

Share this post


Link to post
Share on other sites

The difference is the heavy spring takes about 500 more rpm to engauge than the light spring does. It comes down to rider preference. I've tried the heavier spring and it works well for MX or super aggressive trail riding. But, for my style and riding conditions, the lighter spring serves me better. Less slip, more clutch life.

Remember, if your using the perch adjuster you shouldn't have more than 1 inch of threads hanging out from the end.

Share this post


Link to post
Share on other sites

Light spring, no perch adjuster.( I tried it and hated it. Do a search on the perch adjuster if you are interested, there were a few of us who had one and went back to the external adjsuter. ) Be sure to follow the instructions for engagement and you should be set up just right. :applause:

Share this post


Link to post
Share on other sites

I tried the lighter spring, but could not get the bike into neutral. Unless I slowed the idle way down - then the engine would die sometimes. What gives?

Ed

Share this post


Link to post
Share on other sites

I have the same problem GetSum....I installed mine last week and didnt really have much time to play with the setup. Took it down to southern utah and had a blast with it but it seems like it's engaging too early....Until the clutch heats up it wont go into gear without stalling...when its warm it pulls a little even at idle with the light spring...I think some adjustment is in order.

Now thats its all broken in, im going to check the gap and see if i cant get it dialed in better.

Share this post


Link to post
Share on other sites

Yes, the light spring works great for single track/ trails.

If you're bogging you need to get the carb adjusted or

make sure you have the gap correct in the clutch stack.

Make sure you have the clutch cable adjusted correctly

before messing with the perch adjuster. They do seem to

drag a little when warm, a little adjustment with the perch

adjuster is all you'll need. The biggest thing i've found

with the rekluse is that you need to have the jetting perfect,

or damn close, or you'll stall or think it's a clutch problem.

Share this post


Link to post
Share on other sites
I have the same problem GetSum....I installed mine last week and didnt really have much time to play with the setup. Took it down to southern utah and had a blast with it but it seems like it's engaging too early....Until the clutch heats up it wont go into gear without stalling...when its warm it pulls a little even at idle with the light spring...I think some adjustment is in order.

Now thats its all broken in, im going to check the gap and see if i cant get it dialed in better.

I have the same thing going on with the light spring. It wouldnt go into neutral, and had a jerking issue when just idling! So I put the heavy spring in and have it adjusted at the end. Seems pretty good now.

I messed with the jetting a litle and its better. I can't wait till Fuel Injected bikes comes out!!!! :applause: I HATE MESSING WITH JETTING!!

Ed

Share this post


Link to post
Share on other sites
I have been very happy with my light spring, adjusted so there is almost no slack with the engine off. I ride / race desert from sand, whoops, long loose hill climbs, tight technical hill climbs and trails, fire roads, MX tracks at the GP races, and the occasional "get off and push" through the rocks! :applause: I love mine!!

'01 426

:applause:

So you have the light spring pretty tight? like what - a little more then 1/2 and the adjuster?

Ed

Share this post


Link to post
Share on other sites
So you have the light spring pretty tight? like what - a little more then 1/2 and the adjuster?

Ed

I don't know if I did it wrong from what I have been reading, but the spring seamed SOOO loose when I first installed it, I was worried it would fall off. I moved the light spring as far forward as I could, so there was almost no slack, and I was confident it would not fall off. I have had absolutely ZERO problems with mine from day one! It was great on Saturday to take a first timer out to one of the dry lake beds so they could get the feel for riding a dirt bike, have them fall, pick the bike back up, get on and drive away again without having to re-start the bike!

The only thing that has changed, is that the bike does tend to get hot faster than before, but that normally isn't a problem. It just makes me ride harder and faster! :applause: I have noticed no additional wear on the clutch plates, the Rotella oil is cheap so I change it after every 80 - 100 miles, and it has helped me out of more hairy situations then I care to think about! :applause:

Share this post


Link to post
Share on other sites

Thanks for the pic...I was wondering how people were setting up that external adjuster. I had one nut on either side of the holder, instead of both nuts on one side...my question is...with that bracket so loose, how do you keep the adjuster from falling out? Just spring tension?

Share this post


Link to post
Share on other sites
Thanks for the pic...I was wondering how people were setting up that external adjuster. I had one nut on either side of the holder, instead of both nuts on one side...my question is...with that bracket so loose, how do you keep the adjuster from falling out? Just spring tension?

That was my concern as well. There was just too much slack between the spring and the supplied bracket for my liking. I adjusted the bolt as far out as possible, to take the slack out, then I covered the bolt, nuts, and bracket with some high strength/temperature tape to make me feel better that it wouldn't "fall out". It's not pretty, but it works PERFECTLY! I would post a pic, but it is almost embarrasing! :applause:

Share this post


Link to post
Share on other sites
Thanks for the pic...I was wondering how people were setting up that external adjuster. I had one nut on either side of the holder, instead of both nuts on one side...my question is...with that bracket so loose, how do you keep the adjuster from falling out? Just spring tension?

Yep Yep. The tension keeps her on there. For over a year so far, and some awful, I mean awful mud rides too. :applause:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0