06 yz 450 coolant

i have an 06 450 that goes through coolant like crazy. i replaced the stock radiator cap with an aftermarket cap and it still drains alot. i was running engine ice but that is getting a little expensive. has anyone else had this problem.:applause:

No. How is the coolant getting out? How much? Details?

hmmm I lose a little coolant if I let the bike idle a bit when I am out riding. They do get hot real quick if they are not moving. Could that be part of it?

i have an 06 450 that goes through coolant like crazy. i replaced the stock radiator cap with an aftermarket cap and it still drains alot. i was running engine ice but that is getting a little expensive. has anyone else had this problem.:applause:

I run Engine Ice and love it. I used to boil over quite abit but since going to Engine Ice it rarely spews coolant. The one bottle ($18.00) has lasted me over a year. Maybe there is another issue?

It might be the water pump gasket. I'm not sure if the water pump is the same as a CRF but when I was spewing coolant on my CRF it would come out the water pump drain hole. It may be that your gasket has gone bad on the impeller.

has anyone else had this problem.:applause:

Not at all. My '06 has about 100 hours on it and I just barely added a SLIGHT amount of coolant for the first time. Level has always been fine.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now