HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
otter101

Rekluse pro z start clutch

5 posts in this topic

Alright, who has one, did you install it and was the bike new or old. I have a 06 wr 450 just installed my pro clutch. The clutch basket had no or very minimal wear, the stock friction plates looked good with little or no apparent wear on them. The install went well, the hardest part was torquing down the center clutch nut. My delema starts with checking and setting the gap. First I think I checked the gap between the top friction plate and the bottom of the pressure plate( the rekluse part) and not between the top plate and fiction plate. So I put it together and everything works fine. I ran it for 20 mins or so to. I took it apart to recheck the gap and relized I never checked it in the right location. SO I checked it in the right location and my gap needed adjustment. I took the adjustment plate and fallowed the instructions to install it and the gap was even larger. the instructions say I might need new friction plates. Thats my question anyone else run into this.

Share this post


Link to post
Share on other sites

I just installed one in my 07 yz450f and it works great. I havent had any adjustment problems at all. Its a little wierd to get used to though.

Share this post


Link to post
Share on other sites
Alright, who has one, did you install it and was the bike new or old. I have a 06 wr 450 just installed my pro clutch. The clutch basket had no or very minimal wear, the stock friction plates looked good with little or no apparent wear on them. The install went well, the hardest part was torquing down the center clutch nut. My delema starts with checking and setting the gap. First I think I checked the gap between the top friction plate and the bottom of the pressure plate( the rekluse part) and not between the top plate and fiction plate. So I put it together and everything works fine. I ran it for 20 mins or so to. I took it apart to recheck the gap and relized I never checked it in the right location. SO I checked it in the right location and my gap needed adjustment. I took the adjustment plate and fallowed the instructions to install it and the gap was even larger. the instructions say I might need new friction plates. Thats my question anyone else run into this.

Does it run OK?

If not, is the gap big enough for to throw in another steel plate?

Share this post


Link to post
Share on other sites
I just installed one in my 07 yz450f and it works great. I havent had any adjustment problems at all. Its a little wierd to get used to though.

Good to know... I wan't to get one for my 07. Did you get it with clutch over-ride?

Share this post


Link to post
Share on other sites

I found the answer. I called rekluse and found out I was checking it wrong. I bought a set of feeler gauges the gap now is a tight .045 right in the ideal gap. I took it out today for about 20 miles, WOW WOW it was perfect, not one stall after falling in to the mud, and getting stuck on steep rocky hills, and running up deep rutty, rooty tight trails. Caution way more torque I mean a ton and little or no compression braking on light declines and steep hills. This thing is a great investment in riding.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0