HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
TyeeHusky

2007 WR450 AIS Removal Kit recall by Yamaha

8 posts in this topic

Just got a call from the local dealership that I bought my 07 WR450 from and the AIS Removal Kit is shipped with the wrong jets

The dealer got a call from Yamaha today stating something about a jet mixup. I am taking my bike in so they can verify what came in the kit and what was installed. Something about two of the same jets were shipped or something.

Sorry my memory recall is not so good but I am bringing the bike in to be looked at. They did say it should run like crap if the wrong jets were installed.

So If you have a new bike with AIS installed and it runs like crap call your dealer.

That is all I know but will know more tomorrow

Share this post


Link to post
Share on other sites

Ok,

Got back from the dealer today. Still a little fuzzy for me but sounds like the first shipment of AIS kits went out with two main jets or leak jets. It is the two small ones that come with the kit. I know I am being real technical. Anyway they are going to take my carb out and see what is in it. It runs great so not sure if a mistake was caught by the shop. I talked to them about installing a JD kit for half the price since they would have the carb out already and they are all for it. Sorry my info is not better but that was 7 hours ago and these carbs have to many jets.

Share this post


Link to post
Share on other sites

my Australian kit has changed carb to175 main, 110 main air, 50 pilot ,DSQ3 needle(3rd pos clip) 45 leak jet, 2 turns out pilot screw. It runs fairly well & pulls strong .I think its running rich it has a slight splutter about1/8 to 1/4 throttle , i have to index my throttle yet to tell the exact position and a slightly black sooty tailpipe.Plug was black on the outside but the inside was a nice brown last time i looked. Any ideas? maybe yamaha might go smaller . I could try smaller to get rid of the soot.

Share this post


Link to post
Share on other sites
Just got a call from the local dealership that I bought my 07 WR450 from and the AIS Removal Kit is shipped with the wrong jets

The dealer got a call from Yamaha today stating something about a jet mixup. I am taking my bike in so they can verify what came in the kit and what was installed. Something about two of the same jets were shipped or something.

Sorry my memory recall is not so good but I am bringing the bike in to be looked at. They did say it should run like crap if the wrong jets were installed.

So If you have a new bike with AIS installed and it runs like crap call your dealer.

That is all I know but will know more tomorrow

I figured something was wrong with the jets the kit came with. My bike had a 70 air jet in it and the kit came with a 110 to replace it. Thats a pretty substantial bump. Let us know if you find out more or what Yamaha is going to do to fix it.

Here is a pic of the jets side by side. The left is the 110 from the kit and the one on the right is the origional that came with the bike.

Dirtbikes003.jpg

Share this post


Link to post
Share on other sites

Just got the updated jet from dealer. It is a #110 Main air jet just like the one in the above post. I'm pretty sure thats what came in the original kit that I got. Gonna check in the morning to make sure. If thats the case, I think there may still be something off. I've noticed that it stalls easily, compared to stock, with the kit. Almost like it has little or no flywheel weight.

Share this post


Link to post
Share on other sites

i have a wr450 2007 model and have just done all the mods to it and it is missing wile i am mid throttle going on the road just wondering wot jetting is being used as the ones that come with the bike are not the right ones ?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0