HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
dbehr624

Clutch???

4 posts in this topic

Hey guys, I was at the track this weekend and i was having some problems with my clutch. Whenever i would kick it into gear from neutral, my bike would die unless i increased the RPM and then kicked it into gear, and it also rolls when its in gear with the clutch all the way in. I played with the adjuster on the bars, but to no avail. So what is the problem and how do i fix it? Thanks guys.

Share this post


Link to post
Share on other sites

Try adjusting your clutch cable down by the motor. If that dont help check your clutch plates and see if there burnt up.

Share this post


Link to post
Share on other sites

Sounds like the same thing that happened to my stepson's KX100. After sitting in the garage all winter long, oil drains out of the plates and can cause them to stick together. Try working the clutch while riding it, pop it in and out.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0