piston woes

just got my bike back from the shop. rode two days, about 20miles and fried the head and valves. got big bore. je piston and all of a sudden the motor shutdown. first thing i checked was oil and coolant. both were fine.next i noticed the header pipe was completely loose at the motor. bolts were finger loose. tore it apart this morning and fried the head completely and found out the je piston in there was for a 2004 and ive got a 2005, different part numbers from JE website and just would like some feedback if possible. if the loose header could have done some damage and if the wrong year piston was put in there could that have done it as well.....thx

just got my bike back from the shop. rode two days, about 20miles and fried the head and valves. got big bore. je piston and all of a sudden the motor shutdown. first thing i checked was oil and coolant. both were fine.next i noticed the header pipe was completely loose at the motor. bolts were finger loose. tore it apart this morning and fried the head completely and found out the je piston in there was for a 2004 and ive got a 2005, different part numbers from JE website and just would like some feedback if possible. if the loose header could have done some damage and if the wrong year piston was put in there could that have done it as well.....thx

The piston dia is the same from 01-2007.

There is a cylinder head difference only making a compresion rario change.

Only a few cc diference in dome volume from 04-05.

I think upon a queck look that the 04 piston in a 05 would lower comp by a very small amount

And still you are working with a flat top od mild reverse dish piston.

Your jaw would hit the floor if you saw how much dome is on the Factory bikes.

i need to clarify more. ive got an athena big bore in the bike with a pressed in steel sleeve from the midwest. the bore is now a 98mm and it is a JE piston that i just pulled out of it, cross referenece part numbers the piston that i pulled out is for a 2004 wr and mine is a 05 and they have different part numbers. not sure if this would effect anything but you never know cause they are two differetn part numbers from JE website. there was too much heat and i was only riding it half throttle if that on the highway....

anyone with some feedback is very welcome. could use someones advice that knows

anyone with some feedback is very welcome. could use someones advice that knows

PM grayracer (moderator on the YZ side) and point him to this thread. He's a wealth of knowledge and should have an answer for you.

A loose header will cause it to suck air which will in turn cause a lean condition. I really believe that is what caused your problem.

yeah thats kind of what i was thinking as well. just drop it off at the speed shop and the guys a very stand up guy and is gonna do the right thing and get me back on the road soon. one other thing is the hot cams are really shitty,were taking them out and putting the stock ones back in....one out of 15 bikes hes worked on with those cams is actually working....

Take it back to the place that did the work, they stuffed it.

edit, just read above post.

yeah the mechanic is going to take care of me, just wanna ride, you all know what i mean

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now