Trail Tech XR650L Temp sensor install..

So I got the new air-cooled sensor for my Vapor. It WILL NOT fit under the sparkplug. So I checked to see where I could install it and found the oil line and installed it there. I checked the motor temp with an IR temp gun and they were only about 2 degrees diiferent. I think this will work good. Check out the pics..

http://www.putfile.com/pic.php?img=4850028]5420185839.jpg

http://www.putfile.com/pic.php?img=4850026]5420184815.jpg

i would think if your temp readings are matching up well it would be a good spot, seems well protected and out of the way :applause: . take another ride and see if it shows the same as the ir gun under varying conditions.

How/when did you get it? I've had a order in for 4 months and the trail-tech website has been down for quite a while, I'm starting to think they are having problems.

I got it last week. They posted on here they were in stock so I called them and they sent me one FREE!! They said they were not putting people on a waiting list just to call them back every other week.

I have the same issue on my R, you put it where the outer crush washer was on that oil line?

Good think to know!

I'll email them, hope they'll send me one to Spain too.:applause:

I have the same issue on my R, you put it where the outer crush washer was on that oil line?

It actually fit "around" the crush washer. So I kept it on and put the banjo bolt though it and put the stay back on there. It fits good there and is out of the way from stuff and the wind. Plus I think it will give a better temp reading there with the oil line and head.

It actually fit "around" the crush washer. So I kept it on and put the banjo bolt though it and put the stay back on there. It fits good there and is out of the way from stuff and the wind. Plus I think it will give a better temp reading there with the oil line and head.

I can't tell exactly how it is mounted from your pictures and decription. Could you take a pic from a different angle so we can see it a bit better?

I'm getting ready to install mine tonight. :applause:

Sorry the CHT did not fit the spark plug.

What is the bolt diameter? 8mm?

Geoff@trailtech.net

Well it does fit around the plug. But the head has no clearance for the sensor to fit in it's a tight fit. But this spot seems to work so far.

Whats a good temp reading for normal conditions? What's the danger zone for the 600R (assuming the operating temp is the same as the L?)

Do you have a e-mail adrress where i can buy this setup and also a front steel

braided brake line? for a XR-650L. Steve

Whats a good temp reading for normal conditions? What's the danger zone for the 600R (assuming the operating temp is the same as the L?)

Can anyone help me out here?

Pleeeeeeeese!

It actually fit "around" the crush washer. So I kept it on and put the banjo bolt though it and put the stay back on there. It fits good there and is out of the way from stuff and the wind. Plus I think it will give a better temp reading there with the oil line and head.

What size is the one you have, 10mm?

I just went out and measured it with the calipers. The OD of the oil line brass crush washers are 13.5mm. I'll go with the 14mm temp sensor. It'll fit under the oil line (between it and the head), around the outside of the inner crush washer (because it's slightly larger), but still be tight against the head to get a good reading.

Thanks for all the help in this thread!:confused:

I also recently installed the same computer on my 97 XR 600R. I mounted the temp probe on top of the head where the engine mount hanger bracket meets the head. I will relocate to the oil banjo fitting.

My problem is: I am not getting an engine temp indication, but the max temp indication is working. I connected the ground wire to the same frame ground that the other electrical components are connected to. Any ideas????:confused:

Can anyone help me out here?

Pleeeeeeeese!

i cant give you exact but i used a infrared temp gun from snapon awhile ago after riding 20 miles on the hiway. i saw anywhere from 350-500 deg f. depending on where i pointed the gun. it was obviously hottest near the exhaust ports.

i would go out and get one and do some different riding scenarios then record the temps from the gun. this way you can get a good baseline for the temps you want.

I also recently installed the same computer on my 97 XR 600R. I mounted the temp probe on top of the head where the engine mount hanger bracket meets the head. I will relocate to the oil banjo fitting.

My problem is: I am not getting an engine temp indication, but the max temp indication is working. I connected the ground wire to the same frame ground that the other electrical components are connected to. Any ideas????:confused:

If you didn't reseted the computer after attaching the sensor, then here's the problem.

I was riding out toward Tecate 3 weeks ago and did a nice little flip over the bars, smashing my speedomter, headlight, and tail light. I have wanted to get the Trailtech for sometime, but did not want to spend the money because there was nothing wrong with mine. Looks like I will be ordering one soon, I like the way it looks, I would like more info on how accurate the engine temp is. Does anyone have the XR's only dipstick and the Trailtech sensor? How does it compare? Any input is appreciated!

James

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now