xr 600r pouring white smoke

just had my 95 xr600r rebuilt new pistons rings timing components and valves

brought it home and it had a small hesitation or misfire and a pop like decelleration pop the next day i started and it was pouring white smoke i shut it off and carried it back to the mechanic. he is having trouble finding the problem. he is a very repected mechanic in my town any advice would be appreciated.

Normally white smoke is from burning coolant. Since there is no coolant, it has to be oil that is burning. The smoke from a super rich condition is black, so again it has to be oil smoke. How about the fuel. Did you put new fresh gas in the tank? Any chance that there is oil in the gas?

There are only a few possible sources for the oil. It's either getting past the rings or getting down the valves. If it is severe, I'd guess that something either broke or was not installed. Could be a missing/broken ring or missing valve seals.

I guess that it is possible that the rings just are not sealing yet, but I kind of doubt it.

How long did you run it with white smoke? How did it sound? hows the oil level? any leaks? if it sounded ok and the oil level is ok then I would chance running it for a minute or two to see if the smoke clears. you can run alot of smoke from a little oil. If it is enough oil to run it dry, it will probably foul the plug first. You may have residual oil in the combustion chamber/head from the rebuild.

Hey bass. I recently rebuilt mine and it does the same thing. I took the carbs (86) and exh. off and looked at the valve stems, they are dry so nothing is getting by the seals. It smokes pretty bad at start up (white) but stops after 30-45 sec. I hope it will stop after it is run for a few hundred miles. Mine is running rich , i will fix that and see. I think once the rings are set good it will stop, I also had my valve seats re-cut so they might need to be run awhile also. got about 2 hrs. on it so far. why don't you post the results from your mech. i'am interested. Tim

Yall bring dem smokers down here to fix dem skeeters!

just had my 95 xr600r rebuilt new pistons rings timing components and valves

brought it home and it had a small hesitation or misfire and a pop like decelleration pop the next day i started and it was pouring white smoke i shut it off and carried it back to the mechanic. he is having trouble finding the problem. he is a very repected mechanic in my town any advice would be appreciated.

"carried" it back to the mechanic. I haven't heard carried (instead of "took" or "take" for us yankees) since summers at my Grandma's in S.Carolina 35 years ago. :lol:

i would say a valve is or was hanging/stuck open, that would explain the misfiring and the smoke

Mine has never backfired, but I get the white cloud every now and then.

Gas it a couple of times and POOF its gone...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now