HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
Insaneman1731

Problems with 426.

8 posts in this topic

There is 2 problems that I noticed with my 426. While reving it, it soudns like its making a sucking sound of some sort..not sure how to explain that one. And if I am in first gear or so, give it gas and slow down, or just at random times, there is a clanking noise..something that i think is from the engine..i thought it wast he skid plate rattling, but I don't think its that. And help is appreated. Thanks.

Share this post


Link to post
Share on other sites

If your chain is a little loose it could be slapping on the chain guard on the top of your swing arm. On my 426 if I was going slow and twisted the throttle it would almost soind like a heavy slapping noise. It could be that this guard may be loose and the chain may be hitting it against the swing arm. Just a thought.

Share this post


Link to post
Share on other sites

Do you have an aftermarket skidplate on the bike? If so, they can reflect much of the sound of the chain back up to the rider, especially with a low rpm roll-on. I drilled holes in my skid plate and it eliminated the reflective noise. As far as the sucking sound is concerned I don't really have any ideas on that...:lol:

Share this post


Link to post
Share on other sites
Do you have an aftermarket skidplate on the bike? If so, they can reflect much of the sound of the chain back up to the rider, especially with a low rpm roll-on. I drilled holes in my skid plate and it eliminated the reflective noise. As far as the sucking sound is concerned I don't really have any ideas on that...:lol:

Yes I do have an aftermarket skidplate.

Share this post


Link to post
Share on other sites
There is 2 problems that I noticed with my 426. While reving it, it soudns like its making a sucking sound of some sort..not sure how to explain that one. And if I am in first gear or so, give it gas and slow down, or just at random times, there is a clanking noise..something that i think is from the engine..i thought it wast he skid plate rattling, but I don't think its that. And help is appreated. Thanks.

The sucking noise might just be intake honk, our old trail 90's and my dad's xl200 had it really bad, so far I ahven't noticed any on my 426. Clanking is just chain slapping, it doesnt always mean your chain is too loose but that your lugging it

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0