HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
dedminst

LED turn signals

8 posts in this topic

I installed, or at least I tried to install a set(4) of mini LED turn indicators on my 04 XR650L yesterday but they would not blink. They would only illuminate. Does any one have a solution?

Share this post


Link to post
Share on other sites

The LED's don't draw enough current to operate a standard flasher. You need a flasher for LED turn signals. Look around and you should be able to find one as they are fairly common. The other option is to use a resistor in parallel with the signals to draw more current and operate a standard flasher..

Share this post


Link to post
Share on other sites

Well, I just got back from Baja Designs after purchasing their LED flasher unit, and promptly installed it. The lights do indeed flash now, BUT, they all flash at the same time! Any ideas as to what may be wrong?

Share this post


Link to post
Share on other sites
Well, I just got back from Baja Designs after purchasing their LED flasher unit, and promptly installed it. The lights do indeed flash now, BUT, they all flash at the same time! Any ideas as to what may be wrong?

The turn signal indicator is causing this. It needs to be unplugged when using all LED signals.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0