LED turn signals

I installed, or at least I tried to install a set(4) of mini LED turn indicators on my 04 XR650L yesterday but they would not blink. They would only illuminate. Does any one have a solution?

The LED's don't draw enough current to operate a standard flasher. You need a flasher for LED turn signals. Look around and you should be able to find one as they are fairly common. The other option is to use a resistor in parallel with the signals to draw more current and operate a standard flasher..

they have it a bajadesigns

I just got mine working same thing

Thanks guys! I'll let you know happens in a couple of days.

They can be bought at most good auto parts stores they are called an electric flasher.

Well, I just got back from Baja Designs after purchasing their LED flasher unit, and promptly installed it. The lights do indeed flash now, BUT, they all flash at the same time! Any ideas as to what may be wrong?

Well, I just got back from Baja Designs after purchasing their LED flasher unit, and promptly installed it. The lights do indeed flash now, BUT, they all flash at the same time! Any ideas as to what may be wrong?

The turn signal indicator is causing this. It needs to be unplugged when using all LED signals.

You can replace the indicator light with an LED and it will work normally.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now