HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
lizziez03

03 YZ250F ... popping/backfiring... glowing exhaust

2 posts in this topic

My '03 YZ250F has recently started backfiring and popping on deceleration and on idle and also stalls when coming to a stop. Made some adjustments to the fuel screw and it helped a little. Cleaned the carb hoping this would help and when I started it up last night and let it run for about 2 minutes, I noticed that the exhaust pipe at the cylinder was glowing red (maybe to about the bend in the pipe). Was wondering if it seems that I have one issue here or multiple? Thanks. Liz

Share this post


Link to post
Share on other sites

head pipe will glow in no air flow.

use the sticky pots at th etop of the forum to set up your fuel screw.

make sure the square end of the slide plate it down and that the hot start cable isnt binding.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0