1987 XR600 won't run!

I just got a 1987 XR600 from a guy on trade. It ran when I first got it but it wanted to die when you gave it a lot of gas. I took both carbs off and cleaned them and now its very hard to start. If it doesn't start on the first kick forget it. Onc I get it started it will run good but it wants to die and also it will quit on me when I give it lots of throttle when riding. It seems to run better since I cleaned the carbs, problem is I can't get it running or keep it running. Any suggestions? I have owned many bikes over the past 30 years but never a 4 stroke dirt bike. I like this bike and would like to ride it but first I gotta be able to keep it running! Oh yeah, how do you get the spark plug out? Special socket ! Thanks for the help

Welcome to Thumpertalk, RShaips....Have you adjusted the valves...

That might help...The spark plug socket I believe is 16 or 17 mm

:worthy::D

I have done nothing other than clean the carbs. Is it hard to adjust valves? The guy I got it from said it did smoke a little at start up but not when riding it. Its 20 years old and looks to have been riden pretty good so I am sure it needs some maintenance. Thanks and

I just got a 1987 XR600 from a guy on trade. It ran when I first got it but it wanted to die when you gave it a lot of gas. I took both carbs off and cleaned them and now its very hard to start. If it doesn't start on the first kick forget it. Onc I get it started it will run good but it wants to die and also it will quit on me when I give it lots of throttle when riding. It seems to run better since I cleaned the carbs, problem is I can't get it running or keep it running. Any suggestions? I have owned many bikes over the past 30 years but never a 4 stroke dirt bike. I like this bike and would like to ride it but first I gotta be able to keep it running! Oh yeah, how do you get the spark plug out? Special socket ! Thanks for the help

Honda makes a special tool for pulling the plug that comes with the bike. My 600 didn't have one so I stole the tool off my wife's 200. I think it's the same tool.

The tool makes changing the plug much easier than with a socket because of the weird shape of the 600's head.

Adjusting the valves is a 30 minute job one you get the tank off and TDC set.

"O"

Is it common to have to adjust the valves due to the bike running poorly? Nothing else in the carb/gas flow area I should check? seems to me to be a air/fuel mixture problem. But I guess that could also be related to valves being out of adjustment or needing a valve job. Thanks

The only time this thing will start is if its totally cold and then it will start on the first kick. It will run great for about 30 seconds or until I try to ride it then it will completly shut down and thats it. Any ideas? Thanks

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now