Red Ignition light?

Dumb question but I would really like to understand this.

The red light on the ignition button. When is it supposed to be on and when is it supposed to be off?

I'm guessing it's on when you press the button on, Then goes off once the engine starts, then comes back on when engine shuts off.

Please let me know if this is right or wrong.

And when I press the button and no lite comes on should I still be able to start the bike?

*by start I mean kick start* My e-button hasn't worked since I first got it used.

My 06' works as follows:

Press Ignition Button. RED light comes on.

Start the motor (Engine running). RED light goes OFF.

If the engine stalls, the RED light will come on.

I'm not sure about the kick starting scenario. Check your battery if you haven't already done so.

Dumb question but I would really like to understand this.

The red light on the ignition button. When is it supposed to be on and when is it supposed to be off?

I'm guessing it's on when you press the button on, Then goes off once the engine starts, then comes back on when engine shuts off.

Please let me know if this is right or wrong.

And when I press the button and no lite comes on should I still be able to start the bike?

*by start I mean kick start* My e-button hasn't worked since I first got it used.

When my battery is low the light won't come on but it kick starts just fine:thumbsup:

The red light is there just to tell you that your "key" is on. Leave it that way and your battery will go dead.

The red light is there just to tell you that your "key" is on. Leave it that way and your battery will go dead.

Exactly, its your ignition light only.

ok. I think my battery was just drained, but after being towed for 5 miles it charged itself cause last night the light was fine. Thanks for clearing it all up guys I thought that was it but some stuff has been goin on with the bike and just wanted to make sure to help me troubleshoot ignition/running problems. I believe the problem i'm having is just a spark plug, I will be changing that today at lunch and hopefully have a working bike again :mad:

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now