HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
taggart400f

400f clutch problem

4 posts in this topic

need advice on why my clutch won't dis-engage. seems as if the pushrod assembly doesn't make contact with pressure plate until 3/4's out. Any advice is good advice thanks

Share this post


Link to post
Share on other sites

disconnected cable can manualy turn shaft to actuate pushrod, also have clutch cover off to watch pushrod does not contact plate until very end of throw

Share this post


Link to post
Share on other sites

That's not that abnormal. There is a lot of free travel in the actuator/push rod, which is why your cable is adjustable. You could have a damaged or missing release bearing on the outer push rod, or a missing push rod separator ball, however..

If you can't get the clutch to release cleanly enough to find neutral at an idle, and all the free play is set up correctly, you may have a grooved basket or warped plates.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0