Engine Stalling Out

Hey all. Went out to ride this past weekend and got about 6 miles into the trail and started having problems.

The throttle quit being respsonsive and then the engine started just cutting out and couldn't keep it running.

Afte pushing for about half a mile I though, Try the fuel screw. Turned it in about half a turn and she was back to running. Ran her about 10 minutes or so and figured all was well and that the fuel screw had just back itself off. Well we took a little break later on down the trail, then she wouldn't start back up and run. I could start it but it would die soon. Tried messing with the fuel screw and wasn't ever able to get it back to running. Ended up with a two strap on my buddys swing arm and my handlbars. Pretty interesting! ANyway I'm thinkin something as simple as a dirty carb. maybe a jet clogged or block. Just wanting any other suggestions. The ignition light flickers indicating to me that the engine is cutting out. Let me know what you all think. Help is greatly appreciated.

Could be a bad spark plug.

Could be a dirty carb/air filter

Could be bad valve clearances or bad valves

Could be faulty ignition coil.

Could be either of the above but I'd start with checking the carb, remove it & clean it out meticulously. I say this because of you fiddling with the fuel screw had a sort of reaction, probably some dirt in there.

Streetbike Pimp - Thank you for the list of things to try I appreciate that incase the carb cleaning donesn't work.

Beejay - Thats what I was thinking since after adjusting the fuel screw all seemed to be fine for a little while. Adjusting a fuel screw wouldn't exactly fix an ignition coil.

I suppose it could have had some effect on spark plug, and I don't think it would effect valves but I dunno enough about the engine to say one way or the other.

Thank you for the replies guys.

Sounds like a blocked vent on the gas cap.

If it was a blocked vent how would I have been able to get it working with the fuel screw the first time? Not saying this isn't possible. Just asking for someone else to confirm the possibility of it? I just got to work for the day and can't just walk out and check the vent.

Don't bother worring about the ignition coil until you've ruled out the other 3 items on the list.

But, I did list it because I have been burnted twice by a faulty ignition coil. Both times the bike would stumble/stall at low rpm speeds and all of the symptoms made you beleive it was a low speed jetting issue (pilot jet, ac pump, leak jet, etc). The last time the coil burned me, I messed around all summer with my jetting, and wasted the whole riding season before I replaced the coil.....

I'm gonna swing by the shop tonight after work and try a spark plug. I've already got my can of carb cleaner, but figure I'd try replacing the spark plug first since it's easiest.

Ok, i've been looking for the sparkplug here in the manual and am not having any luck. Where exactly is it located on the bike? Sorry for the dumb question but my bike isn't here infront of me to look at. Damn work won't let me bring it in. haha

Well, I installed a new plug today during lunch break and to no avail. I think I wore my battery down from all the kicking while trying to adjust fuel screw with new plug. Now the red light doesn't turn on. Is there anyway to recharge the battery without a tender and without being able to ride it? Like how far would it need to be pushed to charge back up? more thatn I'd wanna push i'm assuming. Carb is coming off this week as soon as I get a chance.

Problem finally solved. Maybe one to out in your head.

It seems the lazy 15 year olds working at my local shop caused me a good 3 weeks of distress just cause they were too lazy to fix a mistake.

Appearently when they were checking out my estart the forgot to reconnect the Ground wire for my magneto/entire electrical system. Then were too lazy to go back and do it after putting the bike back together. I notcied the spark of the ground wire shorting out on the case while messing with it last night (while it was dark outside). Terminated the ground lug and VOILA, what do you know. She runs good as new again. Never letting that shop touch my bike again. Thank you all for all the ideas and help you've given me. This Forum is Awsome.

Problem finally solved. Maybe one to out in your head.

It seems the lazy 15 year olds working at my local shop caused me a good 3 weeks of distress just cause they were too lazy to fix a mistake.

Appearently when they were checking out my estart the forgot to reconnect the Ground wire for my magneto/entire electrical system. Then were too lazy to go back and do it after putting the bike back together. I notcied the spark of the ground wire shorting out on the case while messing with it last night (while it was dark outside). Terminated the ground lug and VOILA, what do you know. She runs good as new again. Never letting that shop touch my bike again. Thank you all for all the ideas and help you've given me. This Forum is Awsome.

Glad to hear you located the problem and it was a minor fix. More often than not the problems are small, but cause major headaches in trying to figure out what is wrong. That is why this forum is great. Imagine how big your manual would have to be to convey even a fraction of the information/knowledge found on this website.

Cheers.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now