Idle Issues

I have a yfz450 cam in my 05 with the cam mod done. The bike runs extremely strong and has a hard pull all the way to rev limiter. My problem is that when I coast down a hill with the clutch in, it will die. It also wont idle without the choke on. I just adjusted the vavles, hoping it would help, but no luck. Then I tried to change the jetting, but ended up only one needle position from where I was. What do you guys think it could be?

Try changing to a richer pilot jet like a 48 or 50 and opening up your fuel screw at least to 2 turns out.

I have a 50 and my fuel screw is around 2.5 turns out.

Well my buddies with the YZ450 end up going leaner with the pilot. Some of them run a 40 or 42 pilots to get the YZ450 to idle right. But we have an ACV circuit on our carbs so we need to richen it up 2 jets to be at the same flow as theirs on a leaner pilot. I am confused why your bike runs with the choke but wont idle. It is worth a shot but leaner may be worth trying. Is your ACV cirucit bypassed? :thumbsup:

Sounds like a clogged pilot jet...how long has it sat between rides??

Check the fuel screw is assembled correctly. I had a similar problem when I lost the little o-ring off it. It was sucking air, leaning out the idle mixture so going bigger on the pilot made no difference.

My acv is not bypassed and my fuel screw should be fine. It doesnt have an vacuum leak. I ride my bike at least once week (used to be 1-2 times a day until I got a job). It didnt start doing this until I did the cam. I also dont believe it is the pilot because it will fire up after a kick or two, hot or cold (e-start takes a little bit). Power is immediate and pulls all the way to the limiter. I just took it to the marysville mx park on sunday and it did pretty good. Could it just be something with the timing?

Is there anyone who makes a stronger threading for the hot start cable that goes to the carb? I dont believe my leaks, but the threads are garbage.

Is there anyone who makes a stronger threading for the hot start cable that goes to the carb? I dont believe my leaks, but the threads are garbage.

procircuit.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now