HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
mfracing19

off idle bog

4 posts in this topic

YFZ 450 with no cam mod. Has a Dr.D Pipe with a GYTR header, K&N filter with pro flow and air lid removed. Im at 6000ft elevation and can't seam to get it jetted right. I think this is causing my off idle bog. Any suggestions?

Share this post


Link to post
Share on other sites

Check out the Jetting Database that's stickied to the top of the index.

I don't really care for K&N filters at all (they're too hard to service, and they don't filter well if they don't get oiled right). YZ450 air boxes had no lid. What did you remove?

Share this post


Link to post
Share on other sites

So he did. In that case, he's in the wrong forum. Some of the quad guys in the YFZ forum should be able to help him.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0