Break light trouble

I have a Baja Designs duel sport kit on my 97 XR 600 R and the headlights work, the turn signals blink and the break light turns on when I apply the rear break, But it does not stay lit when the head lights are on. Any ideas? :thumbsup:

Bulb???

I thought there was no way it would be the bulb, and it was'nt, but when i put the bulb back in after checking it to make sure it was'nt burnt out, it worked. Thanks

I thought there was no way it would be the bulb, and it was'nt, but when i put the bulb back in after checking it to make sure it was'nt burnt out, it worked. Thanks

That so weird, I just fixed my 98 XR600R Baja Designs tail light yesterday. I had the same problem you described. No light. Remove 2 screws, pull reflector out of housing and test for voltage with a meter - is good. Test bulb with meter - is good. Put bulb back, throw switch - is good. Put back in tail light housing - no light! To make a long story shorter it ended up the black ground wire (center) was pushing against the connector tab for the tail light breaking the connection when the assembly was bolted up but not when hanging loose. The other side (brake) was not getting pushed off. Solution was to pull the black wire over to one side using a tie wrap. I reassembled tail light and works perfect now. :thumbsup:

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now