HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
MindBlower

Baja Design tailight question

4 posts in this topic

My brake lights not coming on. Running light is lit. Can the bulb fail this way?

I've got the troubleshooting guide from BD to use if not.

Share this post


Link to post
Share on other sites

Not uncommon for the bulb housing to break off inside the assembly. Remove the lense & check the wires where they are soldered inside the bulb socket. Also, the male/female connectors under the seat are not the best. Pull them apart, make sure they're clean & reassemble. If they are a bit loose, lightly crimp the female ends with pliers for a tighter fit.

Share this post


Link to post
Share on other sites

Very common. It's a 2 filiment bulb. The brake one is probably bad. For some reason I used to go through a bulb about every 2 months or so.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0