426 cutting out after half throtol. Also revs on its own

The 426 just got a boysen excelorator pump cover and a home made power now insert.

I started it up seemed fine. I drove it to a open field hit full throtol and it almost stalled so i let off thinking it was too cold and rode easy for little while.

I was coming to a turn and pulled in the clutch and it just starts reving on its own getting in the high rpm. After a couple seconds of it reving on its own it went back to normal. it did that off and on.

So by now ithought it would be heated up enough so i gunned it coming out of a turn and it started cutting out. It has no power after half throtol now. The low end feels good but some times when I shift it bogs for a secont but only some times. But like i cant give any more than half throtol or what it does is looses almost all power and starts poping loud or else it just looses ALL power and roles till i let off.

So whats the fix?

come on any one got a idea even? mabey a biger main jet? it does flow more than when i got it.

Hi, getdrunk. :thumbsup:

Hi, getdrunk. :ride:

:cry: I dont know him.

Now whats wrong with this motor. :thumbsup:

Hi, getdrunk. :thumbsup:

So true...

So true.

As far as i know barch88 you could be "getdrunk".

now back to the motor

As far as i know barch88 you could be "getdrunk".

now back to the motor

That's why you made it a point to show yourself in the "Hey Getdrunk" thread about the powerband... :cry:

Threatening? Yeah right, it said YOUR WRONG. OMG i gess im bad. not
:ride: Im French.

But maybe because the homemade parts you put into it... :thumbsup:

does power now insert mess up the jetting?

you might have an air leak maybe forgot a gasket or something. looked in the manual yet?

:cry: I dont know him.

Now whats wrong with this motor. :thumbsup:

what??? Am I drunk? :ride:

If you are going to try and play stupid, keep the stories straight. Either you can act like you don't know it is a person, or you can claim not to know him. You know, it's kind of funny, you actually have to have some sort of intelligence to play stupid. hmm. Who'd a thunk it?

To answer your question...a bigger main jet is not going to do you any good. Since we know who you are and we know you are putting this motor together, did you bind your throttle when you hooked it up? Is it routed correctly? Did you get all kinds of crap in your carb when doing your homemade kit?

My personal thoughts: You didn't take enough care putting your motor back together and now you are stuck with a POS.

My personal thoughts: You didn't take enough care putting your motor back together and now you are stuck with a POS.

exactly. or it was just a pos to begin with.

and I have proof that this is getdrunk. he sent me a weird PM. I fwd'ed it to brian and bryan letting them know.

Try reassembling it and be very careful of air leaks and make sure to put o-rings where they need to be. If you do that and it still has the same symptoms then take out you homemade powernow because that is probably the source of your problems.

I have proof that this is getdrunk. he sent me a weird PM. I fwd'ed it to brian and bryan letting them know.

He sent me a PM too, haha...he's like "shh, about me being getdrunk and all." :thumbsup:

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now