HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
tx426

Exhaust popping when I let off

10 posts in this topic

Ok, as I said before, purchased a used 02 426, and when I let off the gas get a lot of popping back from the exhaust. Sounds almost like an old straight pipe on a 57 chevy I used to own.....ok, so I am dating myself I know...I am an old fart. Have I got a lean jetting problem? Did I mention that thing runs like a scalded rabbit?

Share this post


Link to post
Share on other sites

> Air leak in the exhaust system.

> Lean idle mixture (1-Adjust, if that fails, then, 2-increase the pilot jet size)

Troubleshoot the problem in that order. If you rejet to cure an exhaust leak, your idle will be too fat, and you'll have starting problems.

Share this post


Link to post
Share on other sites
Ben, you are really pimping out that link today!

Yeah, it's my favourite webpage! :thumbsup: It's a good one, don't you think? It sure beats typing too!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0