HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
MountainMax

Backfiring on decel help guys

6 posts in this topic

Hey guys, I had my bike jetted according to the stick above for 06 450's and had the ais removed, upon decel she would backfire, I got it to stop by turning out the storm fuel screw 3 turns, I was told i need to put in a bigger pilot jet to fix this, I put in a 50 PJ and it's the exact same thing, should I go bigger again? Im afraid to leave my mixture screw out that far as it feels like it may fall out (it's loose that far out, not much spring tension left). what should I do next? I also tried to move the needle up (clip down to position 4 on stock needle) with no difference either, also disconnected TPS, still same effect. should I go up to a 52 pilot? my plug looked black on the inside rim but my electrode was nice and light tan,

Share this post


Link to post
Share on other sites

When I had that problem, the vacuum plate on the carb slide was up side down.

Take your carby off and the half moon cut out should be on bottom BOTH sides!

I got a spare 52 pilot jet if you want it. I dont need it any more! :excuseme:

Funny thing is, I got it to run quite good..........

Share this post


Link to post
Share on other sites

Is your hot start completely off? Any leaks between the carby and cylinder? Float level too low, exhaust leaks, blocked pilot jet, blocked carby breather.

Share this post


Link to post
Share on other sites

I checked all that stuff, it's all good, However I remember looking at my slide and there was a half moon shape on only one side (bottom) of my carb slide, you say it should be on both sides? i never done anything with it?

Share this post


Link to post
Share on other sites
I checked all that stuff, it's all good, However I remember looking at my slide and there was a half moon shape on only one side (bottom) of my carb slide, you say it should be on both sides? i never done anything with it?

Should be on bottom, front and back.

The vacuum plate can fit upside down, with half moon cut out on top.

why they would make it like that, I don't know?

Correct orientation:

http://www.pbase.com/jdjetting1/image/25566144

It will definately give you these symptoms you are having.

Read this for a laugh!

http://www.thumpertalk.com/forum/showthread.php?t=340111

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0