2006 WR 450 tripmeter help

the tripmeter got put put back to 0 in every setting is there any way that i cant get back the old amount of miles or are they lost?

Which trip meter you talking about?

Trip A gets reset to 0 every "race mode" setting and ALSO if you disconnect mains power (battery).

Trip B should not reset unless you push the RESET button.

I suggest you read the manual for a fuller (8 page) explanation...

and the main odometer should not reset at all.......

yea the main main odometer got put back to 0 and i'm pissed i've tryed everything &%$#@! and than every time i start my bike my clock is always back to 12:00:00 whats goin on???

I thought the manual says you lose both A and B mileage. I guess I will have to look again.

yea the main main odometer got put back to 0 and i'm pissed i've tryed everything &%$#@! and than every time i start my bike my clock is always back to 12:00:00 whats goin on???

Sounds like a power issue to me.

I don't have an '06, so I can't really help.

Do they have an internal battery or a wire to the starter battery? That's where I would be looking.

does your dash light up with the key on or do you have to start it first? you may have a blown fuse, mine reset trip A everytime i turned mine off when i blew the main fuse.

no it lights up

yea the main main odometer got put back to 0 and i'm pissed i've tryed everything &%$#@! and than every time i start my bike my clock is always back to 12:00:00 whats goin on???

That is very Odd and not in the "normal" function of the thing at all. I would concur that you have some internal reset going on. Sounds like the Odo is at fault. The main Odo should not reset at all as stated earlier by other TTers. I would suggest a trip to yamaha, maybe they will check it out for you. :applause:

and the main odometer should not reset at all.......

I do not understand "main odometer". I also am having a problem with my trips resetting after a power drain. For instance, on the trail when the bike is warm, if I try the e-start without pulling the hot start and too much battery power is used, my trip will reset to 0. This is aggrevating because I want to keep track of total miles on the bike.

I have read the manual, and pretty much only need the basic mode. I understand there is a trip A and B, but not main odometer.

Any suggestions?

I dont know anything about a "main" odometer, if there is one, I cant find it. however, I had my battery disconnected for a week and the A and the clock reset. I am usually pretty good with written directions, but the 8 pages Yammy gives has me at a loss

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now