XR 650L - Electrical problems - Nothing with Key but will compression start.

Help. :applause:

I went riding yesterday and when I got back the Electrical wont work.I took it up the McKinney/ Rubicon trail from tahoe so it was pretty bumpy but I did not crash or anything. I actually did not get to far because of all the snow.

The bike will compression start and the lights come on etc but the electrical does nothing when I turn the key. I checked the battery connection and it is all good. Lights horn and everything work once started.

Before I go home from work today and take a look does anybody have any suggestions???

Do the Lights horn and everything work before push starting ,

sounds to easy but maybe bad battery ?

Stupid Hondas & their safety switches were a problem until I just removed them all. You have a clutch safety switch, a kickstand safety switch & a neutral safety switch. Probably some more I can't remember right now but I had a few similar problems getting it to start.

Simply bypass them & remove them & chuck them in the nearest dumpster! :applause:

Stupid Hondas & their safety switches were a problem until I just removed them all. You have a clutch safety switch, a kickstand safety switch & a neutral safety switch. Probably some more I can't remember right now but I had a few similar problems getting it to start.

Simply bypass them & remove them & chuck them in the nearest dumpster! :applause:

Easiest way to temp. bypass ALL the safeties is to take both clutch-switch wires, and ground them both.

Top bypass everything, its not enough to just connect them together.

Its a pain to wade through the schem to see why this is, and I keep saying I'm going to produce a simplified schematic of the safty circuit. Just gotts sit down and do it...

Dave

Dave,

A simple schematic would be great. I keep thinking that the only thing that I don't trust on my L are those safety switches.

Fuses? in black box.

I need to do something about my switches too.

About half the time, my bike won't start in gear with the clutch in. A pain if I kill it on the trail.

Once started everything works.

I checked fuses yesterday.

Kickstand is bypassed. I dont kw about the clutch.

New Battery about a month ago.

I will check the nuetral and clutch bypass tonight.

Thanks,

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now