HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
paul69

oil change

3 posts in this topic

I just did my first oil change since getting my 2002 WR 426 its done 3000 kms and in the oil filter there was some swarf and fine particals .

should i be worried ? i just thought it maybe from the gears as they use the same oil.. :crazy:

Share this post


Link to post
Share on other sites
I just did my first oil change since getting my 2002 WR 426 its done 3000 kms and in the oil filter there was some swarf and fine particals .

should i be worried ? i just thought it maybe from the gears as they use the same oil.. :crazy:

or from the clutch.

I think it is pretty normal a search will show that everyone, including me, finds some metal in the oil..

I change my oil more often than that though...

Share this post


Link to post
Share on other sites

im going to do it every 1000kms,,when i got the bike it had 1990 kms on the clock.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0