Radiator leaks out the overflow YZ426F

I RIDE MY 01YZ426F ALOT AND SHE HAS ALWAYS RAN GREAT..THE OTHER DAY I WAS WARMING THE MOTOR UP AT THE TRACK AND RADIATOR FLUID STARTED TO DRIP OUT OF THE OVERFLOW TUBE, AND WHEN I REVVED THE MOTOR IT POORED OUT. I RODE THE REST OF THE DAY AND THE BIKE RAN GREAT AND THE LEAK SEEMED TO STOP. :thumbsup: THE NEXT DAY I CHECKED THE RADIATOR FLUID AND IT WAS JUST BELOW THE FINS SO I PUT SOME MORE FLUID IN AND STARTED THE BIKE AS SOON THE BIKE WARMED UP IT DID THE SAME THING. IF ANYONE HAS ANY IDEAS IT WOULD BE A BIG HELP THANKS. :thumbsup:

Sounds like you are slightly overfilling the radiator and letting it get to hot while warming it up. My 426 will spill out any water higher than half inch above the fins, sometimes as low as the fins. If it spills out more than that I'd check your radiator cap.

Its normal. The 426 needs air to flow thru the radiators to keep it from boiling over.

I THINK IM GOING TO GET MY RADIATOR CAP PRESSURE TESTED BECAUSE THE BIKE JUST STARTED TO DO THIS AND I HAVE HAD THE BIKE SINCE 2001.HAS ANYONE EVER HAD A RADIATOR CAP GO BAD? IF YES WHAT MAKES THEM GO BAD? :thumbsup:

sure radiator caps can go bad especially after a few years. they don't hold the right amount of pressure anymore. but then again what do I know. Just :thumbsup: replace it.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now