HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
mtrdrms

How often do you change spark plugs?

12 posts in this topic

Just trying to get a feel for how long they last. I have an 06 with about 6-8 hours on it and it feels a bit sluggish. I havent looked at the plug yet but I thought since everything else is perfect this could be the problem.

Share this post


Link to post
Share on other sites

Wait,do these bike's have spark plugs?It's been so long i forget.All kidding aside,when mine start to rust I change them.

Share this post


Link to post
Share on other sites

I don't change them unless they foul and I've not had that happen for awhile now, current plugs been in there for over 6 months. Sounds more like you need to service your airfilter.

Share this post


Link to post
Share on other sites

On my 2000 426, I changed the plug twice in four years....I haven't even puled the plug on my 2005 450. On that's with one and a half seasons of desert races.

Share this post


Link to post
Share on other sites

I change mine yearly when I tear the bike down for it's greasing and carb teardown. It may not be necessary but a year of riding on a plug is plenty for me.

If your bike feels sluggish, have you re-jetted it? Clean air filter? Is the bike stock?

Share this post


Link to post
Share on other sites

Had my 05 since June it is on the original plug. Pulled it and cleaned it twice I think..

Share this post


Link to post
Share on other sites

Hmm. Well, good to know. I have rejetted it (170-48)and the airfilter gets cleaned every other ride along with the oil. It hits plenty hard, it just feels like it misses at cruising speed and when I snap it to get over a log or stream it jsut felt a bit tired. Must just be me.

Share this post


Link to post
Share on other sites

I have heard the Boysen Quick shot accelerator pump cover may help you out. I have noticed that slight bog once in a while also, so your not crazy...

Share this post


Link to post
Share on other sites
Hmm. Well, good to know. I have rejetted it (170-48)and the airfilter gets cleaned every other ride along with the oil. It hits plenty hard, it just feels like it misses at cruising speed and when I snap it to get over a log or stream it jsut felt a bit tired. Must just be me.

Try a air screw adjustment, maybe it has loosened a little. Do you have a zip-ty yet?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0