HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
MOmilkman

Anyone run aftermarket hubs!? I need help?

1 post in this topic

Does anyone have their front stock hub lying around they might want to sell for a reasonable price?

I have replaced my front wheel bearings 4 times since I bought the bike and as I was getting ready to replace them again tonight I am starting to lean torward the fact that the problem might be the hub and not the bearings.

Both bearings check fine (no play) but you can easily slip the bearing in one side of the hub with your hand. (no socket tap in method)

I imagine this is the source of my problem.

Anyway its a 99 WR400. Let me know if anyone has anything they might be willing to part with.

Thanks!

------------------

Darin in Missouri - My Hurricane 1999 WR400F

Enduro Heaven - Ozark Mountain TrailRiders

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0