HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
taksx

05 Tail Light

7 posts in this topic

Anybody have any issues with their tail light?

mine stopped working, bulb is still in good shape, head light works fine.

Any thoughts :thumbsup:

Eddie

Share this post


Link to post
Share on other sites

Do you have a multimeter available? You could just verify if you are getting voltage to the light by checking at the connector under the seat. That is, if it's the same setup as the '06.

Share this post


Link to post
Share on other sites

Hi,

I was fighting with mine, those connection really :thumbsup:

I finally changed to LED rearlight and hook it to battery.

Timo Mc

Share this post


Link to post
Share on other sites
Did you check the plug in connector thats right under the seat??

Yup its pluged in.

I finally changed to LED rearlight and hook it to battery.

Is it always on or do you have it set up when you brake it turns on?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0