HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
dirtbikindad426

'06 YZ450F Question

6 posts in this topic

I had my new Yz450F out at Mesquite MX park for it's first real ride after breaking it in. My son and I both rode it and later in the day it seems like a plug (welch plug or freeze type plug) fell or blew out of the case on the left (shifter side) and it was pouring oil out all over everything. Has this happened to anybody else?

It is back at the shop I bought it from and they are fixing it but I wanted to know if this is a common problem with the new 450 engines.

DBD

Share this post


Link to post
Share on other sites
Just take a center punch and stake the edges...Tdub

I guess I will have to do that when I get it back from the dealer. They have it to check it out and replace the plug. They better change the oil too.

Share this post


Link to post
Share on other sites
Did a search and found where it happened to one other guy. Has it happened to anybody else?

I saw you found it, happened only a couple days ago to letmein. There was at least another post some weeks earlier, but I could not find it using the search words "oil, leak, plug, or case" :thumbsup:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0