Sign in to follow this  
Followers 0
Derik Tate

Backfire

8 posts in this topic

Just installed my new exhaust , frame guards, skid plate , bark busters, new 168 main and #48 pilot, zip Ty fuel screw. Shit now I'm broke! Anyway i have read about the backfire :thumbsup: do to the smog pump and have ordered the kit from TT. I sure hope that this stops that annoying popping. I put a Jardine exhaust slip on. Holy crap thats loud. I should have bought the Q2 instead. :thumbsup::bonk: Anyone looking for a new pipe? Got one here.

Share this post


Link to post
Share on other sites

I just bought the Jardine full race exhaust system and I am also getting the horrendous backfire. I can completely close my fuel screw and the bike still runs. Currently, the fuel does not do much. :thumbsup: I am also running with a 48 pilot and a l68 main. What year WR do you have? Isn't the AIS kit on 2004 WR's and later?

Psychoone

Share this post


Link to post
Share on other sites

first check for any exhaust leaks not only at the header but all the way back after that checks out pull your plug white is laen black is rich tan is just right. i no leak i bet it is lean.

Share this post


Link to post
Share on other sites
I just bought the Jardine full race exhaust system and I am also getting the horrendous backfire. I can completely close my fuel screw and the bike still runs. Currently, the fuel does not do much. :thumbsup: I am also running with a 48 pilot and a l68 main. What year WR do you have? Isn't the AIS kit on 2004 WR's and later?

Psychoone

That is classic exhaust leak. I would loosen everything up a bit, hold the header on square on the gasket, tighten up the header nut and bolt EVENLY, a little turn each till it is tight.

Tighten up the rest of the exhaust system and make sure the header outlet is square to the midpipe inlet.

You will be amazed of what the tiniest leak will do, to your jetting and not to mention the flames it would spit!

Share this post


Link to post
Share on other sites

Same thing here. I was told that the AIS removed should help eliminate the prob. I have checked for leaks and i find nothing.

Share this post


Link to post
Share on other sites

06 WR450F.....FMF Factory 4 slip-on, stock header...same problem here, backfiring. No loss of power though. Waiting on AIS kit to see if that solves the problem.

Share this post


Link to post
Share on other sites

my fuel screw has to be turned way in for it to run great with this smog thing. I hope that when i remove it i will have to open the screw back to normal settings. 06 450 mine is on back order until next week. I hope that it gets here b4 Feb 17 for my Whiterock ride.

Share this post


Link to post
Share on other sites

MXJunky installed the TT AIS removal kit on his '05 WR450, no more annoying backfiring. The bike runs so much better without that smog shit. (MXJunky also has the Q2 silencer and JD jet kit, with airbox holes cut.)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0