HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
kenny168

Starting 04 Yzf450

4 posts in this topic

My son has a yzf450 when he starts it the head pipe glows red very quickly and to me seems to back fire alot. I ride two strokes and just got a new kxf450 yesterday :bonk: dont know much about them yet but love these web site helps out alot.Ithink its running to lean and he to adjust fuel screw HELP ANYONE :applause:

Share this post


Link to post
Share on other sites

The glowing header is the "please ride me" indicator light (normal, but can increase when lean). The backfiring could be caused by the header or midpipe leaking, or it may just be a lean mixture. Make sure you have a good seal at those locations. It could be leaner because of cold weather and you can open your fuel screw about a half turn to see if it improves.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0