2003 WR wont start,

I took my 2003 WR 450 out to ride for the first time and electric starter worked great all day. Went to load it up and nothing. Even the little red light on the ignition quit working. The battery is new and checked out at 12.4 volts. Does anyone have any suggestions. Your help would be greatly appreciated. Thanks

I'd use a volt meter to check for current at the switch and then at the starter motor. I could be something as simple as a loose ground or pinched wire. Worst case, the starter motor is toast, but I doubt that. Its usually something simple, like a bad connection.

I took my 2003 WR 450 out to ride for the first time and electric starter worked great all day. Went to load it up and nothing. Even the little red light on the ignition quit working. The battery is new and checked out at 12.4 volts. Does anyone have any suggestions. Your help would be greatly appreciated. Thanks

Check the fuses by the battery.

Thanks guys. I checked the fuses. They look good. I hope that is a bad connection. It kinda sucks to buy something and it takes a dump the first day. I appreciate the input!

Do you have any accessories on the bike that could be drawing current? I just had the same thing happen, turns out the previous owner wired the hot grips into the dc curcuit instead of the ac so when I shut the bike off and left the hot grips switched on they killed the battery in no time.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now