Sign in to follow this  
Followers 0
drive805

UH OH... should i worry!

14 posts in this topic

01 WR 426 .....changing oil, pulled out filter and there are metal chips in the filter should i worry?

I am the second owner and the first took meticulious care of it as i have so far but now i dont' know if i should trust it for riding is this normal?

anyone please...thanks in advance!

Share this post


Link to post
Share on other sites

Not unless they are big chips. It's common to get small particles of metallic looking stuff caught in the filter. My bike has been doing it for years. Zero problems.

Share this post


Link to post
Share on other sites
Not unless they are big chips. It's common to get small particles of metallic looking stuff caught in the filter. My bike has been doing it for years. Zero problems.

Same here. When I STOP finding small particles in the filter, that's when i'll start panicking. :banghead: It's common for these bikes.

Share this post


Link to post
Share on other sites

It's because the engine shares it's oil with the trans. The metal shavings are from gear teath, clutch basket/hub, etc, and perfectly normal.

Share this post


Link to post
Share on other sites

WHEW thanks i've only had it a short time and wanted to make sure that something wasn't coming apart..

Share this post


Link to post
Share on other sites

Yup, me too. At first I freaked out, I was getting flecks too (about the size of pepper). But no biggie, each time I change the oil, the filter has flecks in it, not alot so I don't get too worried. Realize this bike revs like a banshee out of hell, it's a wonder I don't get chunks of metal pouring out with each oil change.

Share this post


Link to post
Share on other sites
How often are you changing filters?

I have the metal screen filter, I read you can just rinse it out and pop it back in. This is what I have been doing. Anyone else?

Share this post


Link to post
Share on other sites
I have the metal screen filter, I read you can just rinse it out and pop it back in. This is what I have been doing. Anyone else?

Yep, me too but even with the cloth filter I only replaced it about every 12th ride or fourth oil change.

Your all good :banghead: Just keep changing that oil and you'll have little or no problems

Share this post


Link to post
Share on other sites

yer , my 426 looks like you have been panning for gold when I was washing out the filter.......and so did my last one, and my buddys one !!

Share this post


Link to post
Share on other sites

i have never changed the filter just washed it out, i have only had the bike about 6 months and have done 2 oil changes i was told to check and clean the filter about every third oil change i wanted to see what it looked like so i did it this time!

also i am using synthetic oil that is all the previous owner used and he said that i should stick with it!

Share this post


Link to post
Share on other sites

I usually wash it out three or four times then maybe if I have extra cash when changing time buy one then if not rinse it out or blow it out with air good to go.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0