HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
Max Power

i think i have a real real big problem on my hands.

23 posts in this topic

My bike is putting out too much power. It doesn't matter what gear I'm in, it just takes off and I can't contol it. Help me please with sugestions. Anyone.

Help! Sum pictures below of what iam taliking about. Help.

Please.

1013739-L.jpg

1013709-L.jpg

1013737-L.jpg

8219198-L.jpg

35835841-L.jpg

38812038-L.jpg

Share this post


Link to post
Share on other sites

You obviously are running over 140psi in your front tire, just lower it to the proper specs, will make turning much easier too.

Share this post


Link to post
Share on other sites

get rid of that red power band immediatly! go with the green or yellow one.....they are very calm compared to the snappy red one.

Share this post


Link to post
Share on other sites
You obviously are running over 140psi in your front tire, just lower it to the proper specs, will make turning much easier too.

My bike will not do over 100 mph let alone 140. What gives?

Maybe my oil level is too high?

Share this post


Link to post
Share on other sites

I think it's a case of the power band ran to tight. I have had the same problem but, it was worse when hitting mounds of dirt:

garage.php?do=viewattachment&attachmentid=971

I went 680cc and a pumper carburetor and it fixed it for a little while but, sure enough it came back.

Share this post


Link to post
Share on other sites

psi, as in too much air in the front tire causing it too lift constantly, not mph as in top speed...

jeez the rookies :banghead:

Share this post


Link to post
Share on other sites

oil is way to high, i usualy run about half a quart in my gas tank and i poour about a gallon in the head through the plug hole.

Share this post


Link to post
Share on other sites
psi, as in too much air in the front tire causing it too lift constantly, not mph as in top speed...

jeez the rookies :banghead:

tires need air? aint they just rubber?

Share this post


Link to post
Share on other sites
get rid of that red power band immediatly! go with the green or yellow one.....they are very calm compared to the snappy red one.

How could I say no to the "Red power band" sales lady? She was quite hot.

8625743-L.jpg

Share this post


Link to post
Share on other sites
You obviously are running over 140psi in your front tire, just lower it to the proper specs, will make turning much easier too.

no...

he's just expirimenting with the new Helium inflation devices for the front end.

To hear it told, it sure makes that front end light.

and :applause: where do I talk to that red powerband sales lady, maybe I could convinvce her to let me try out the pink one :banghead:

Share this post


Link to post
Share on other sites
psi, as in too much air in the front tire causing it too lift constantly, not mph as in top speed...

jeez the rookies :applause:

Crikey..... Must check my PSA. Thanks. :banghead:

Share this post


Link to post
Share on other sites
no...

he's just expirimenting with the new Helium inflation devices for the front end.

To hear it told, it sure makes that front end light.

Yes.... yes it does.

Share this post


Link to post
Share on other sites
the one at the top of page 2 (this page)

Your sales lady needs to lay off the booze.

Oh my eyes.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0