HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
4Takt

Installed Edelbrock carb in my 650R, not sure I like it...

41 posts in this topic

I installed an Edelbrock Quicksilver carb on my XR650R after reading all the praises here. I'm a bit confused by the results.

First, it does make a bit more power than the stock carb. That I like.

However, it bogs and hesitates as I open the throttle, much more so in fact than the stock carb. If I putt along near idle and abruptly open the throttle, the engine dies.

I tried to adjust the pump, but strangely it has almost no effect. Even at standstill, just blipping the throttle, there is no pump setting that results in zero hesitation.

Speaking of pump settings, someone here recommended fine tuning it in 1/8th turn increments, but mine is nowhere near that sensitive. Except for all the way in or all the way out there is just no discernable difference at all.

It starts no easier than the stock carb either.

I run the stock exhaust with drilled out tip. Do I need to drill the side panel, does the Edelbrock need more air (the stock restrictions are removed of course)?

So far, the stock carb was crisper and more responsive with less hesitation, and that can't be right, can it?

4Takt

Share this post


Link to post
Share on other sites

Nope it's not right. Maybe you have a defective pump. I would call Edelbrock. They will make sure your set up right and then mail you free of charge the parts needed. You can pull the carb and make sure the float bowl is full. Then operate the carb manually and watch the squirt. No squirt or very little when you adjust it means there is something wrong with the squirt circuit.

Share this post


Link to post
Share on other sites

Something is not right and it sounds like the pump isn't working correctly as already illuded to. The stock bike with a properly tuned stock carb should start right up cold without any issues. This carb won't make starting any easier from a cold start, but it will make starting much easier if your bike goes down.

Did you install the carb stright from the box or did you by chance take it apart to look inside? If you took it apart to look inside, there's a small check valve that will fall out of the float bowl if you weren't looking for it and if that happens, then you pump won't work. This has happened to a few people who got curious about the inside of the carb.

Share this post


Link to post
Share on other sites

I did take the float bowl off, and the check valve did fall out. I put it back in, per instruction sheet tip down (as the carb is mounted), correct?

How can I check the pump?

If I disconnect the pump/throttle connection and manually push the pump as the bike is idling (no throttle), what should it do to tell me it's working? Should the rpm go up?

4Takt

Share this post


Link to post
Share on other sites

It would be very hard to put that piece in wrong. It simply slides into the drilled hole, but without it, the pump won't work correctly.

The way to check it manually is to simply twist the carb out of the rubber boots so you can see through the carb. You'll want to be looking at the back side of the carb (airbox side). Then make sure the fuel is turned on and give the throttle a couple of quick full twists as you're watching the back inside of the carb. You should see a stream of fuel squirt from the the inside of the carb. It should be very noticible. If fuel is being supplied to the carb and you're not seeing any fuel squirting with quick full twists of the throttle, then something is wrong. Either no fuel is getting to the carb (unlikely since your bikes runs) or the plunger assembly isn't working or the check valve is missing and or not properly seating or the passage where the fuel is being shot from is obstructed.

Share this post


Link to post
Share on other sites

Pls keep us posted on the outcome..I have seen mixed results on the Edelbrock. .interested in it myself but not until I hear more definitive results.

Share this post


Link to post
Share on other sites

Hi there was a post somwhere in this forum (do a search on Edelbrock ) which mentioned the same problem. it turned out the gasket and plate on the float bowl has a hole to allow the fuel to pass through the pump circuit to the carb throat. the hole was not drilled in the right place from the factory(opposite side) thus blocking the fuel.

it might be worth checking

i am very happy with my Edelbrock

good luck

Share this post


Link to post
Share on other sites
Hi there was a post somwhere in this forum (do a search on Edelbrock ) which mentioned the same problem. it turned out the gasket and plate on the float bowl has a hole to allow the fuel to pass through the pump circuit to the carb throat. the hole was not drilled in the right place from the factory(opposite side) thus blocking the fuel.

it might be worth checking

i am very happy with my Edelbrock

good luck

That was me.

The hole in the plate with the gaskets on both sides was drilled on the opposite side. The gasket has two mirror image holes in it, someone at the factory drilled thru the wrong hole. Take the float bowl off and you'll see a hole were the fuel comes up from the pump, goes thru the hole in gasket/plate, thru a corrisponding hole in the carb body and out the nozzle.

After I discovered the error, I drilled a new hole on the proper side.

Bingo, it works fine now! :banghead:

Share this post


Link to post
Share on other sites

Short update:

The pump is working, I can clearly see the squirt when looking into the carb.

Called Edelbrock , they suggested I play with the needle position. I initially rode the bike with the stock needle position (12 clicks out). It popped on deceleration, so I went up until it stopped (15 clicks out), and concentrated on the pump setting. Edelbrock says the two aspects play together and I may have to go richer on the needle still. Very helpful folks. As soon as this current Hurricane is through I'll find some time to fiddle a bit more.

Another bummer: The bike starts sputtering like it's running out of gas a good bit before I'm actually down to reserve (stock tank). Switching to reserve fixes that (if you want to call that a fix).

The carb makes great power though, but.... :banghead:

4Takt

Share this post


Link to post
Share on other sites
Short update:

Called Edelbrock , they suggested I play with the needle position. I initially rode the bike with the stock needle position (12 clicks out). It popped on deceleration, so I went up until it stopped (15 clicks out),

4Takt

hi i am a bit confused. when popping on deceleration it means it is running lean so if you turned the mixture screw to 15 clicks out surely that would lean it out more and make it worse. i found that mine was not filling up quickly enough (>10 secs) as the float needle was sticking as soon as i freed needle up it filled in less than 3 secs and cured my popping. i am at 12 clicks out and 1.75 on AP

Share this post


Link to post
Share on other sites
hi i am a bit confused. when popping on deceleration it means it is running lean so if you turned the mixture screw to 15 clicks out surely that would lean it out more and make it worse.

Hmmm, the Edelbrock manual says clockwise = richer and ccw = leaner.

I added 3 clicks cw. Maybe it's a semantic problem, but thats what I meant by saying I "went up" untill the popping stopped.

4Takt

Share this post


Link to post
Share on other sites

i love my edelbrock carbs.

after many thousands of baja miles using dirty fuel the needle valve (fuel enters carb) has chocked up a couple times. I think the carb-like all carbs-is sensitive to varnish from sitting to long....now at the end of my rides i turn off the fuel and let the bike burn up the fuel in the carb.

Share this post


Link to post
Share on other sites
Hmmm, the Edelbrock manual says clockwise = richer and ccw = leaner.

I added 3 clicks cw. Maybe it's a semantic problem, but thats what I meant by saying I "went up" untill the popping stopped.

4Takt

i am with you now. like i said ihad the same problem. i richened mixture till popping stopped but still had acceleration problems until i checked float bowl filling up at correct rate voila!!

Share this post


Link to post
Share on other sites

Alright, I spent a lot of time with this carb now. No matter what I do, I can't get rid of hesitation and bogging when I abruptly open the throttle from very low rpms. I went richer on the needle as per Edelbrock 's recommendation and it got worse. Between 15 and 17 clicks out it works the best. The pump is working, I can see the jet of fuel when I whack the throttle, yet pumper screw adjustments seem to do very little except for extreme settings. I checked the valve, the bowl fills quickly, so that ain't it either.

All in all, the stock carb never hesitated so bad, and that's supposed to be the stocker's weakness.

I will probably keep the Edelbrock for two reasons:

1. It does start on the first kick when the bike is hot, even if I dumped it. That might be worth the price of admission right there.

2. It does make noticeably more power than the stock carb.

Am I expecting something that's unreasonable? Those of you who have their Edelbrock dialed in perfectly, tell me this:

If you chug along slightly above idle, and whack the throttle open all the way, does your bike stall?

I'm getting used to the carb enough now that I can deal with it, but it certainly doesn't respond anything like I expected a pumper carb to respond, from what I read about them.

I have nothing to compare it to.

4Takt

Share this post


Link to post
Share on other sites
...Those of you who have their Edelbrock dialed in perfectly, tell me this: If you chug along slightly above idle, and whack the throttle open all the way, does your bike stall?

Absolutely positively no stalling when chugging along above idle and quickly changing to WOT. I do this countless times each and every time I ride.

Are you sure the problem isn't with your bike? Is your idle speed turned up enough. Have you checked your valve clearances, particularly your intakes which have a tendancy to tighten up with time? Are both of the airbox restrictors removed from your bike? Are you definitely running the non-EPA manifold or a stock one that's had the restrictor plate cut out?

Something isn't right with the bike or the carb. Depending on the terrain and hookup, your front end should jump up and or your rear tire should spin when you whack the throttle all the way open from just above idle. There should be no stalling whatsoever when modulating the throttle under normal circumstances.

Share this post


Link to post
Share on other sites

There isnt a fourstroke on the planet with a solex type carburetor that you cant kill by wacking the throttle wide open from an idle.

If it was a CV, its a different story.

Share this post


Link to post
Share on other sites

I have 3 edelbrocks--all 3 you can wack the throttle off idle and have instant response. Thats one of the nice things about this carb.

You seem to have been focusing on the needle height....BUT the squirt AMOUNT is far more likely the issue. Yes it is squirting-but how much?

If its too much squirt you can have the effect you are describing. If i was you i would spend 20 minutes adjusting the pump. To little or to much and it will hesitate off idle.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0