HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
waterdog3

stupid question.....

11 posts in this topic

got myself an aluminum clutch cover. went to remove the stock cover, put oil pan under it. when i pulled the old cover no oil came out, but everything had an oily coating. i did not start the bike before hand and the bike had not been started for several days. is this normal???????

Share this post


Link to post
Share on other sites

That seeems really odd. I know when I installed the rekluse clutch I had to lay the bike on it's side to keep the oil from running out :D

Share this post


Link to post
Share on other sites
got myself an aluminum clutch cover. went to remove the stock cover, put oil pan under it. when i pulled the old cover no oil came out, but everything had an oily coating. i did not start the bike before hand and the bike had not been started for several days. is this normal???????

It is a dry sump system, did you just run the engine? Normal if you did. Now if it sat all night and did this...

Share this post


Link to post
Share on other sites

The bike was cold, don't think i started it that day. I thought it was odd, but i have never had the covers off before. I check the oil level every day before I ride. Yes, after a 1-2 minute warm up. It has been showing about 3/4 up on the dip stick. The bike runs and pulls hard...

Share this post


Link to post
Share on other sites
what kind of clutch cover? i cracked mine this weekend.

In other words, he'd lile to buy your old "take off" unit! :D

Share this post


Link to post
Share on other sites

no i would like to get a blue one but i've only found one for $150.

my engine sounds different after the break - was it b/c the sound is coming from the gaping hole?

Share this post


Link to post
Share on other sites

I got it on e-bay.$80.00, brand new alluminum. They retail for around $175.00. I have my factory cover. u can have it for the shipping cost.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0