HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
moto9

Cam Timing Help Needed

4 posts in this topic

Does any one know the trick to setting the cam timing.

I had to replace a broken connecting rod and need a little help setting the timing on the cams.

Thanks

Share this post


Link to post
Share on other sites

The lobes should face outward/opposite to each other. In otherwords, the punch marks on the cam sprockets should be visible on the top edge and vertical from a side view of the engine. Also the mark "I" should line up on the rotor in the hole. The timing chain is easier to install when you put it on the exhaust sprocket first. Take your time on it. Hope this helped...

Share this post


Link to post
Share on other sites

What engine? Stock cams or aftermarket? Using a 450 cam in a 426? A few details are needed.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0