Amsoil Oil leaking extensive through breeder tub! It amsoil the best oil

I am running Amsoil on my yz 426 it runs outstanding with it! I can hear no engine noise no valve cliquing all the noise comes from the exhaust only when I replace the oil filter very fell metal shaving on it if any! Well the problem is that every time I rid it I have to add a ½ cort because seams it leeks from the breather tub I wonder if any one knows what I can do to stop it? I was ticking in make a small tub adaptor to go in on the factory tub

how much oil are you putting in the bike? Usually that is a sign of to much oil.

I usually put 1 and ¾ of court I check the deep stick and add if needed before I ride and bikes is cool! Usually I ad a ½ after every ride

you shouldn't have to add 1/2 court after every ride :D, are you checking your oil when the bike is cold??, because if you check it when its cold the oil level will show a lot lower as it is in the cases and not circulating round the frame and engine :D . oil normally drips out of the breather tube untill it is at the right level. :D

I usually put 1 and ¾ of court I check the deep stick and add if needed before I ride and bikes is cool! Usually I ad a ½ after every ride

Does it smoke? Cause a 1/2 quart after every ride is very excessive, and would lead one to start looking a worn oil control ring. Drain the bike and fill the oil exactly as the manual describes and check the oil exactly how the manual describes!

it do not smoke and live no oil marks on my garage! anybody have any idea how to fix it or what cause?

Hello,

you have too much oil in your bike. Fill the oil into the bike like described in the manual and said above. It is very very important to change and measure the oillevel when the bike is hot or at least warm. Start your bike, run it for 2 minutes and the check your oil. You are blowing the over filled oil out through the breather.

Martin

I usually put 1 and ¾ of court I check the deep stick and add if needed before I ride and bikes is cool! Usually I ad a ½ after every ride

The 00 426 uses just a little more than a quart. 1 3/4 will puke out the tube every time, and it most definately should not need more after a ride.

I run Amsoil in my bike an love it too! Got about 20 degrees less engine temp an easier starting. I also had LESS blow by for the breather tube.

Sounds to me that you may be putting too much oil in your bike! The book says check your oil warm.

Appreciate your help I will try again this week

I run Amsoil in my bike an love it too! Got about 20 degrees less engine temp an easier starting.

You have actually measured that decrease?

it do not smoke and live no oil marks on my garage! anybody have any idea how to fix it or what cause?

Buy a Billywho Factory Fill from the TT Store. It has markings on the side of the bottle so that you know exactly how much oil is going into your bike, and it also tells you how much oil your bike needs. Your problem is your putting to much oil in your bike. its not good, you need to let your engine breath. Its drowning and your losing horsepower because all the moving parts have to slosh through pounds of oil.

Fix: Billywho Factory Fill

Cause: You. Stop filling your bike up with more oil than it needs.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now