oil leaks from breather hose every ride

i posted this before and was told oil level was to high, lowered level but continues to leak, any other advise on what to do, my 2000 426 leaks alot, so does my 02 426, but not my 03 450, all use the same oil motul 3000 series 10/40wt,they leak about almost a capfull in bed of truck,

I am running Amsoil on my yz 426 it runs outstanding with it! I can hear no engine noise no valve cliquing all the noise comes from the exhaust only! The problem is that every time I rid it I have to add a ½ curt because seams it leeks from the breather tub I wonder if it is because a synthetic oil? Are you running synthetic too? Does it happen w/ other brands of oil I never tried any other brand beside Amsoil synthetic!

i think it is just the 426 because you both seem to have problems with just the 426

I am running Amsoil on my yz 426 it runs outstanding with it! I can hear no engine noise no valve cliquing all the noise comes from the exhaust only! The problem is that every time I rid it I have to add a ½ curt because seams it leeks from the breather tub I wonder if it is because a synthetic oil? Are you running synthetic too? Does it happen w/ other brands of oil I never tried any other brand beside Amsoil synthetic!

Oil brand would have no bearing on the breather hose blowing oil.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now