HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
cheekz

rad on my 450?

5 posts in this topic

i started it up this morrning left i worm up for bout 7 mins and wen i went 2 get it there was steam coming from the rad but not like a kettle, i cut it out and checked the water and it was fine checked both rads and no problem i even checked just now wen i got bk and it if fine. do they do that? :applause:

Share this post


Link to post
Share on other sites
i started it up this morrning left i worm up for bout 7 mins and wen i went 2 get it there was steam coming from the rad but not like a kettle, i cut it out and checked the water and it was fine checked both rads and no problem i even checked just now wen i got bk and it if fine. do they do that? :applause:

Sounds like either water condensation from storage or left over from the last washing was in the fins. I usually run my engine after washing so the heat can get any moisture out of areas I don't want it to be. This is very important with aluminum because many of the minerals and chemicals in tap water can cause corrosion. That's why you should never top off a radiator with the garden hose.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0