Need Help Fast!!!

Ok im leaving in an hour to ride and i just noticed that this little bolt just below and left of where the decomp. cable goes (on the cylinder-right side) is loose and when i tighten it i can only get it like finger tight because it must be stripped or something? Does anyone know what it is and if its ok to ride (i know my description of where it is sucks :applause: ) THANKS

Damn, sounds like the decomp shaft retainer bolt. There is a notch on the decomp shaft, the end of this bolt rides in it and keeps it in the head. The shaft may come out if the bolt is not there. Oil may also leak out here, but not a huge amount.

It is held on by a grand total of about 4 threads, I managed to jerk these out of mine also. You may try and find a metric heli-coil kit, if you know your way around a drill and tap you should be able to install this in about 30 minutes or so (I wouldn't do this w/out removing the head cover to keep debris out of the valvetrain).

I dunno, if you are desperate you may try a bunch of silcone on the bolt and then reinstall it, and, if possible, let the silicone cure some.

If it were my this is what I would do but, like many other things I do, I wouldn't necessarily recommend this....

Hope this helps.

ok, so I think ill go and put silicone on the bolt and then put it in? Is there anything the silicone can hurt inside the head?

Or would i be better of to use locktight?

If I were going to do a glue job like that, and like Hick, I ain't recommending doing it, I would use 3M Super Weatherstrip adhesive, aka The Yellow Death. Put some on the threads, and then cover the bolt head in the stuff.

That's how I'd do it if I did it. And I might, but I won't tell you that.

That's how I'd do it if I did it. And I might, but I won't tell you that.

:applause: Yeah, I think we have all been itchin to ride so bad that we might not done things the right way just so we could get out there.

:eek: Yeah, I think we have all been itchin to ride so bad that we might not done things the right way just so we could get out there.

Thats what I thought... :) but the bad thing is the bolt came out after 3 laps but it was still fun :applause:

A guy at the track was trying to help me get another bolt in it and he said the bolt is just there to hold the decomp shaft in place (like hick said) and we finally got one to work but if u put one in to far u cant turn the shaft and not far enough and the shaft can come out. He said there should be some play on the shaft tho so im wondering if someone can pull on there's and see if it comes out a little? THANKS

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now