HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
martis_d

Clutch problems??

15 posts in this topic

I have a 03 yz450f the clutch makes wine noise and it doesn't dissengage properly but only does it when it is hot. :eek::applause:

Share this post


Link to post
Share on other sites

i have an 03 also but with no problems .ive heard these bikes have had probs with the clutch and you can probably solve the issue with a hinson basket and new clutch. have you tried adjusting it?what type oil are you using?

Share this post


Link to post
Share on other sites

i have tried adjusting the clutch and changing oils from shell advanced to bellray thumper. i will be pulling the clutch apart today and measuring everything in there to see if it is spec. how is the hinson basket different and new clutch is that a aftermarket clutch plates or gen.

Share this post


Link to post
Share on other sites

The Hinson basket has extral oil passages in the fingers to allow better oil flow onto the clutch plates. It may help in your situation.

How hot is was it when you were riding?

Share this post


Link to post
Share on other sites

it was getting real hot the header pipe had a blue glow to it. it was a tight trail so most of it was first gear

Share this post


Link to post
Share on other sites
Stupid question....What kind of clutch lever set up are you using? Stock or other?

I'm using a stock one. the problem is not with adjustment nor with the leaver action but internally

Share this post


Link to post
Share on other sites
do a search on this - there is tons of info on how to fix it....

I done a search but none of the pics worked and after reading all of them i was back to square one :applause:

Share this post


Link to post
Share on other sites

all the springs are within limits, the friction plales are ok but the steels are blue and have high and low spots on them but they seem not to be warped

Share this post


Link to post
Share on other sites
I done a search but none of the pics worked and after reading all of them i was back to square one :applause:

look for 03 yzf 450 clutch fix -

there is tons of info on the actual yamaha fix - the yamaha service bulletin with all the necessary parts to fix the 03 clutch

Share this post


Link to post
Share on other sites

there was also metal grab onthe inner basket and i drilled the oil gals out 1 mm bigger and so will see what happens this weekend

Share this post


Link to post
Share on other sites
look for 03 yzf 450 clutch fix -

there is tons of info on the actual yamaha fix - the yamaha service bulletin with all the necessary parts to fix the 03 clutch

the threads are old and none of the links work

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0