Sign in to follow this  
Followers 0
Neil Claydon

Blowing back light bulbs

12 posts in this topic

Does anyone have a cure for this problem.

XR650R , stop and tail bulbs blow with a monotonous regularity. Two bulbs on a 90 mile round trip.

Cheers Neil. :applause:

Share this post


Link to post
Share on other sites

I had the same problem once. I think it is from the vibrations inthe rear fender and not so much electric.

So....I started riding AROUND stuff like Yamaha 's and DRZ's.....instead of just riding OVER them. Worked for me.

Maybe change to LED. Plenty of posts on it.

:applause:

Share this post


Link to post
Share on other sites

So....I started riding AROUND stuff like Yamaha 's and DRZ's.....instead of just riding OVER them. Worked for me.

:applause:

You have to catch them first, Look in my garage

Neil.

Share this post


Link to post
Share on other sites

I adjusted my pedal so the light was always on accidentally. Took a while to figure out why it kept popping the bulb.

Share this post


Link to post
Share on other sites

I had that problem with a aftermarket T/Lamp on my 600R, I found a bulb that had a hook in it that supported the filament in the middle, it was a factory Toyota taillamp bulb, I think, I just run the stock lamp on my 650R and I added another small 94 bulb for the brake lamp in it (rubber socket) no problemo.

Share this post


Link to post
Share on other sites

on some real old Hondas, the tailites would quickly fail if the headlight wasn't on ... in the days of the old selenium rectifiers

Share this post


Link to post
Share on other sites
I had the same problem once. I think it is from the vibrations inthe rear fender and not so much electric.

So....I started riding AROUND stuff like Yamaha 's and DRZ's.....instead of just riding OVER them. Worked for me.

Maybe change to LED. Plenty of posts on it.

:applause:

That is right, if you look the filliment is broken. I went LED and that fixed that.Or you could ride a lot slower :eek:

Share this post


Link to post
Share on other sites
That is right, if you look the filliment is broken. I went LED and that fixed that.Or you could ride a lot slower :p

"If you can't ride fast, get a bike that looks like you can!":applause: :p

Thats why my mate bought an XR650R, He still can't catch me.:applause:

Neil. :eek::)

Share this post


Link to post
Share on other sites

actually, I wasn't sure if they still used the selenium rectifiers, I just assumed its more solid-state these days .. (showing my age) :applause:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0