WR450; Baja Designs kit; keeps blowing the headlight.....

A guy here at work at the mentioned set-up.

Baja Design's told him that it was "probably" his voltage regulator. He changed that, and it is still blowing the headlight.

Any thoughts?

:)

What year is his bike?

When I installed mine on the 03 the same thing was happening. Baja designs has tried a few different band aids for this problem, but it has not been resolved in my opinion.

After he replaces the regulator only run the light on the high beam (60 watt).

Or replace the bulb with a 70-75 for hi and low.

I don't know what the reason is but when you drop below 65 total watt draw (60 for the head light 5 for the tail) the regulators screw up then send un regulated power to both bulbs. I had readings up to 29 volts @5000 rpm.

Baja Designs is right, it is the voltage regulator. But the reason for its failing is in direct result of there kit design. Keep the pressure on them to make it right.

His is an '04.

So, running a higher wattage bulb is a "quick-fix"? (because it can suck up the extra wattage without blowing?)

I got a 100 watter that I don't use. Maybe I will give that to him until BD can solve things.

Hey, BTW, when are you hooking me up with a melon cover like this?

27019101-L.jpg

:)

:)

He should have bought a TRICKDUALSPORT kit

Jim

As soon as oldbones finds us a couple hundred miles of single track in Grangeville I'll met you there and deliever the melon cover personally. :)

As soon as oldbones finds us a couple hundred miles of single track in Grangeville I'll met you there and deliever the melon cover personally. :)

Sweet! He called me last night, and he is starting his exploring. I am there like a butt hair!

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now