Cutting out on the street 650R

Allright, I love the 650R but here is one annoying trait that I am thinking might be inherent to the bike. Bike runs great but some times when coming to a stop it just cuts out for no reason and is a bear to start. Considering the bike normally starts easy when hot and NOT flooded I'm assuming some how it's not getting enough fuel at times when letting off the throttle causing the flame out.

Some days this doesn't happen, and today it happend twice. This may seem odd but today it only happened when there was about 1 gallon burned out but I had it in the reserve position so I don't think it could have been starvation from the tank.

Anyone else have this?

One more thing, just changed the oil again and now it leaks oil ever so slightly from the bottom of the filter cover. I'm thinking it may be time to replace the seal.

try turning the idle up :)

It is a DIRT bike. Get it off the street and your troubles should clear up. :)

First, the oil leak from the filter cover is a pain, I know. Replacing the O-ring every filter change seems to work though. Also the new o-ring should be oiled before installation. At least that's what helped with my bike anyway.

As far as the cutting out,, first, make for sure the choke is not still on. I did that once and sure enough, the bike cuts out and dies. If that's not it, then it's hard to say, problems that could cause that, range from a dirty carb to electrical problems.. No way to know for sure without checking it out.

good luck with it!

L.L.

May just be float level too high.

Check decomp lever for binding or misadjustment.

Yeah, an annoying day with the pig to say the least. Before I even read your responses I decided to open the filter cover since I didn't think I oiled the gasket when I put it on. Thinking the oil would have drained to the crank case and there would only be a little run out.... :) boy was I wrong! I made a nice mess but the gasket is now thoroughly oiled. We will see if it holds its oil tomorrow, if not, I'll buy a new one.

As far as cutting out, it is a rare thing but I wanted to see if others had the same problem. Best advice had to be from Max about being a dirtbike and keeping it off the street :D Good advice, but not going to happen.

Another question. This is the first bike I had with a manual decompress. Per the manual, every time I kick I push until I meet resistance, pull in the decomp and press a few more inches...then back to the top for the full kick.

Is this necessary every time I kick it over?????? Seems like a hell of a drill.

Yeah, an annoying day with the pig to say the least. Before I even read your responses I decided to open the filter cover since I didn't think I oiled the gasket when I put it on. Thinking the oil would have drained to the crank case and there would only be a little run out.... :) boy was I wrong! I made a nice mess but the gasket is now thoroughly oiled. We will see if it holds its oil tomorrow, if not, I'll buy a new one.

As far as cutting out, it is a rare thing but I wanted to see if others had the same problem. Best advice had to be from Max about being a dirtbike and keeping it off the street :D Good advice, but not going to happen.

Another question. This is the first bike I had with a manual decompress. Per the manual, every time I kick I push until I meet resistance, pull in the decomp and press a few more inches...then back to the top for the full kick.

Is this necessary every time I kick it over?????? Seems like a hell of a drill.

Just giving you a bad time. :D

Well, I was going to say "don't change that oring gasket until your next oil change" but I guess it's too late. Now you no what happens when you pull that oil filter cover off with the pig full of oil. :)

I never use my decomp lever. Well except to bump start my bike.

I've lowered my floats (a couple times). My bike still flames out.........but only if I have the idle set low. Crank up the idle speed........no more flame outs. :)

Stock carb, lower float level, turn up idle, 68s pilot jet.... :)

try turning the idle up :)

Its a big thumper, its helps when you are going to be in traffic. turn up the idle. turning the knob to the right is idle up.

Mine does the exact same thing. I've turned up the idle, but haven't taken a test drive yet. Sounds logical because as you say, it runs great everywhere else.

Regarding the decomp. Here's what I do. Seems pretty easy-

Pull it in, push kickstarter down, let go of decomp, bring kickstarte up about a quarter, try to find TDC (the hard spot), once hard spot found (nice to have it about peg high) bring up the kickstarter and kick it.

I did bump the idle yesterday and today it seemed to be fine though I didn't ride it long. Still seeped a tad of oil on my test ride so while I usually don't use a torque wrench on those small bolts, I broke it out and torqued a little. A LITTLE might I add because I've broken bolts in the past on other bikes.

Good god, if this doesn't work I guess I'll have to break down and change the oil and the oil filter cover seal. I'll try to atleast put a hundred on her if the leaking isn't too bad.

thanks for the responses.

Same thing happened to me. Turned out the decomp lever was hanging up. Rerouted the cable, never happened again..

I've experienced the problem that's described too. The float is spot on, but I'll try turning up the idle a tad and see what happens. Its rare, but when it happens its usually after I've been running fast and then coast to a stop, off throttle. I've always attributed it to flooding, because to start it afterwards I've always used the flood clearing drill and its worked every time.

Steve

I've experienced the problem that's described too. The float is spot on, but I'll try turning up the idle a tad and see what happens. Its rare, but when it happens its usually after I've been running fast and then coast to a stop, off throttle. I've always attributed it to flooding, because to start it afterwards I've always used the flood clearing drill and its worked every time.

Steve

Your symptoms describe mine exactly!

Update: I turned up the idle and finally took a decent road ride today. Didn't stall once. Idles better when cold now as well. The idle really doesn't seem much higher when it's hot so I'm happy.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now