Summer Switch

Had the '05 dialed in with JD blue #4, 170M, 1.75 zip and decided to go red needle for the warmer weather (80 degrees or so). Now it won't idle without the choke on :)

I'm at around 500 asl, if anyone has come across this problem let me know ... I'll be in the garage changing it back to blue.

Needle should NOT affect idle.....check the pilot for debris. Make sure you turned the gas back on....

Call me crazy but, I switched back to the blue and it's a-ok .....

ok crazy!!

What size pilot are you running?

Bizarre.....

Confession: after switching back to the blue needle it APPEARED to be running a-ok until, I went riding that weekend and it ran horrible, at least at low speeds. Wouldn't idle, spit and sputtered at low speeds, backfired on decel. Ran fine WOT but other that that - no good. After researching on TT I came across a thread about an imfamous "upside-down throttle plate" and thought hmmmm ... maybe I should double check it out. And sure enough, somebody snuck in my garage while I was asleep and flipped my throttle plate upside down!!! So I got it running good again with the red needle and everything is fine ....... except......can somebody tell me where I can get a lock for my carb so somebody doesn't sneak in and screw it up again?????

...can somebody tell me where I can get a lock for my carb so somebody doesn't sneak in and screw it up again?????

Lock wont do no good, I think its those little Keebler elf guys.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now