HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
bourkeco

Need help w/Spark

5 posts in this topic

Ok Guys Need some help !!

I have a 96 xr650l That will start and runs strong for a short while 1-2 min. then it dies and looses spark if I turn the key off and on it will start again. I have replaced the pickup (or pulse generator I think) and that did not fix the prob.

Any Ideas? :):D:)

Thanks Scott

Share this post


Link to post
Share on other sites

Gee, thanks for the tease. I have a 93 XR650L with a similar problem. Will run for up to 5 minutes then no spark. It might come back in 5 minutes or 5 days, for unknown reason. Suspect stator problem, but not finding much info on good procedure to check

ignition circuit..I hate to start with such an expensive part if I'm not sure it will fix problem. Appreciate any help I can get.

Norm

Share this post


Link to post
Share on other sites

This is usually the CDI, but it can also be the resistor in the plug cap.

Random shutoffs that take jiggling to fix is usually a safety interlock.

If you're stuck, take the 2 wires going to the clutch lever and short them BOTH to ground- all safeties bypassed for cranking and running!

Dave

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0