05 Baja Kit draining Battery?????

I got my bike from a dealer here and they told me the Baja Kit even when installed properly will drain the battery when the light is on. :naughty: I've been riding it and sure enough the battery goes dead when I turn the headlight on while riding. They hooked it up and I'm being told from others that the charging system on the 05 are great and they screwed it up. I also notice if I stall a few times in a row it will drain the battery even on just the running light if I have to re-start it only a few times. I'm bummed! What good is the magic button if I gotta kick it?????? I'd rather throw the E-start away to save the weight! :naughty:

Any help with this is much appreciated!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Anyone? :naughty:

If your electrical system hasn't been converted totally to DC, try running all your lights off AC to save wear and tear on the battery. All the lights will shut off until you start the engine.

Think I know whats going on based on my experiences.

My 03 WR450 has both an 12 volt AC circuit and a 12 volt DC circuit. The stock lighting of about 60 watts is designed to run on the 12 volt AC circuit. The stock charging system and operating system runs on the 12 volt DC circuit.

So when the entire Dual Sport kit is connected to the 12 volt DC circuit, it over works the available DC power.

My bike ran fine with the DS kit for about 1 hour with the headlight on, then the bike started running rough because the battery was slowly being depleted.

Here's another way to look at it. Some of the numbers are guesses, but you'll get the idea.

Stock:

12VAC = 60 watts lighting

12VDC = 30? watts charging, ignition, etc.

Dual Sport Kit (single voltage source):

12VDC = 90 watts (60 lighting and charging, ignition, etc.)

The work around I did was to un-wire the 35 watt UFO lamp out of my kit, and wire it into the stock 12VAC circuit. This distributes the load properly and I have not had any problems since.

If you want, send my a copy of your 05 schematic and info on your DS kit and I'll help you figure it out.

Think I know whats going on based on my experiences.

My 03 WR450 has both an 12 volt AC circuit and a 12 volt DC circuit. The stock lighting of about 60 watts is designed to run on the 12 volt AC circuit. The stock charging system and operating system runs on the 12 volt DC circuit.

So when the entire Dual Sport kit is connected to the 12 volt DC circuit, it over works the available DC power.

My bike ran fine with the DS kit for about 1 hour with the headlight on, then the bike started running rough because the battery was slowly being depleted.

Here's another way to look at it. Some of the numbers are guesses, but you'll get the idea.

Stock:

12VAC = 60 watts lighting

12VDC = 30? watts charging, ignition, etc.

Dual Sport Kit (single voltage source):

12VDC = 90 watts (60 lighting and charging, ignition, etc.)

The work around I did was to un-wire the 35 watt UFO lamp out of my kit, and wire it into the stock 12VAC circuit. This distributes the load properly and I have not had any problems since.

If you want, send my a copy of your 05 schematic and info on your DS kit and I'll help you figure it out.

Thank you! :naughty: This is the information I was looking for. :naughty:

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now